My laptop is running on Ubuntu 12.04.3 and using Tata Photon Plus dongle. I configured the device through the network manager options. It worked seamlessly.

Few days back I received message from Tata Photon that "we are upgrading our network for a better experience. Click ACTIVATE on your photon dialer settings & enter 0000 as PIN to enjoy uninterrupted serives".

Since then photon connection has stopped working though my laptop is detecting the dongle when it is plugged in but it can not establish the connection.

I am not able to find any solution. Any help would be really appreciated.

update --

To further explain my problem, I have noticed that "Enable Mobile Broadband" option is checked though the "Mobile Broadband" icon is "not enabled". I notice these symbol on the tray.

  • Hi Kinjal, where you able to figure out the solution for this? I also am facing the same issue. – Rohith Nandakumar May 11 '14 at 5:49
  • @Rohit - I tried following various sources on the web to resolve this but no result. I tested the same photon device in different system and different OS which worked fine. I came to the conclusion that either my mobile network software is corrupted or there is some hardware issue. I suggest you to first test your device in different system to make sure it works. Just a note that I have been using photon for more than 3.5 years and there was not a single instance where it failed to connect!. So this time I am quite surprised with this behavior. – Kinjal May 11 '14 at 6:37
  • ah man! I was hoping you had found the solution :( My device works fine as it connects without any issues on my dual booted Windows. And I had been using the same stick with Ubuntu some time back. I thought it was an issue with 13.10 or some configuration issue on the vendor side. I will upgrade to 14.04 and try tomorrow. Guess I am stuck with Windows for now :( Thanks for the help! – Rohith Nandakumar May 11 '14 at 11:15

I also had the same problem but fortunately got a solution. Just follow the instructions given in the link "http://www.tatadocomo.com/downloads/dialers/dialup-internet-on-linux.pdf", and I believe, you would also succeed.

  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – David Edwards Mar 4 '14 at 13:03
  • @Prasenjit - I have already tried the above instruction with no result. The strange part is that I have been using the same device for almost 3 years with not a single instance of interruption. Somehow I got the problem few months back and can't figure out right solution. The device works in other system, so it is obvious that my notebook got some issues. – Kinjal Mar 5 '14 at 4:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.