Everything worked fine in previous Ubuntu 10.10. I installed new Natty 11.04 and wireless started behaving poorly.

The performance is so random, sometimes it works fine and sometimes, all it does is connect to the wireless AP and just stall. Doing a ping (AP address) results in 50 - 90% packet loss.

I found http://ubuntuforums.org/archive/index.php/t-1592846.html and the proposed solution helped.

sudo rmmod iwlagn
sudo modprobe iwlagn 11n_disable=0

And to permanently fix this, i just created /etc/modprobe.d/intel-centrino-n1000-iwlagn-enable11n.conf with following line.

options iwlagn 11n_disable=0

Things seem to work fine now.

wlan0     IEEE 802.11bgn  ESSID:"SthaWiFi"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:23:CD:F0:17:E2   
          Bit Rate=150 Mb/s   Tx-Power=14 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-35 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:435  Invalid misc:58   Missed beacon:0

My question, does anyone else have this issue? And is there a better fix for this?

EDIT: No I still do not have a stable connection with the settings above? Has anyone had good experience with N network?

Also, I figured, in 10.10 the N network was disabled. Doing the same in Natty with /etc/modprobe.d/iwlagn.conf

options iwlagn 11n_disable50=1 11n_disable=1

Stabilizes the network, but can only get G connection. Help?

  • iwlagn worked out-of-the-box for me in a test installation on my hardware. Even on a wireless N network. Did you do a clean install or did you do an upgrade to get 11.04? – Thomas Ward May 3 '11 at 2:59

Well Yes I have another solution, perhaps it could fits to your problem or not. I tried the same solution disabling the N network mode, it works but it turns out not to work under N wireless network.

In my case, I was under a WEP encrypted wireless network, this was the reason why I was navigating to slow, with N mode enabled.

Just enable your N wireless mode and change your security wireless network to WPA2 , it will resolve your problem.



Running 12.04 LTS using a Centrino Advanced-N 6200 wireless card. This solution work for me as well. Not thrilled I can't run N, but at least when I use other wireless hotspots I can at least connect. Edit /etc/modprobe.d/iwlwifi.conf

options iwlwifi 11n_disable=1

I was able to get my Centrino Advanced-N 6200 to work by disabling N mode on my wifi router. This is not an ideal solution seeing as I'll be roaming on wireless networks that I can't control. It seems there are ways to disable N mode on the wifi card itself which may also work.

I'd love to see this work out of the box. I'm on Ubuntu 11.10 64bit.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.