1

I tried to set up Ubuntu 13.10, but there are massive focus problems which make it unusable. It don't seems to have something to do with Unity where I found something about focus problems in the web.

While the installation process the first problems happened: sometimes I was not able to press a button with the mouse. In this case I took the keyboard.

But when the window manager is started, Ubuntu gets unusable for me. Sometimes the focus seems to stick in a window. When this is the case, I can move the mouse over an other window, but I am not able to set the focus in it - it stays in the other window. Also if I use "alt-tab". Sometimes it even happens that focus of keyboard sticks in one window and focus of mouse in an other.

The strange thing is that this happens in 8/10 boots. So not every time, but most of the time.

I already tried to use Gnome desktop because I thought it might have something to do with unity, but it was the same there. MS Windows works without problems on this hardware.

I found a very similar question here with Ubuntu 12.04. I also use Chrome so it might be related to it. But for me it happens with all windows if the problems start: Mouse and keyboard focus problem

Have you some ideas? Did you already hear of such problems? What logs might be interesting?

Thanks!

  • Hello, I've been having a similar problem (described here askubuntu.com/questions/595870/… ). For me the problem was solved by swapping to a different mouse (!). The problems only appeared when using a Rat5 mouse, and went away when i changed (back) to a Mionix Saiph 3200. – CalMo May 26 '15 at 5:52
0

I've encountered the exact same behavior over multiple installs on my current hardware. What consistently solved it for me was killing and restarting the x server. A system restart was never sufficient, the glitch persisted after a vanilla reboot.

The method I employed was to first enable ctrl+alt+backspace to kill and restart the x server: http://www.humans-enabled.com/2013/10/ubuntu-1310-enable-controlaltbackspace.html

1.) Hit Control+Alt+t to launch the terminal

2.) Type or paste in the command below into the terminal, hit enter, then authenticate with your user password necessary (below is a one liner):

sudo dpkg-reconfigure keyboard-configuration

3.) Hit enter 5 times, or as necessary, to accept the already-set values for the keyboard settings and arrive at the screen to change the behavior for "Control+Alt+Backspace" (see picture above).

4.) At the screen that says, "Use Control+Alt+Backspace to terminate the X server?", hit the left arrow key to select yes, then hit Enter to save the setting and complete the kbd configuration.

Once done, fire off ctrl+alt+backspace and cross your fingers!

|improve this answer|||||
  • Please don't just add a link. Quote something (at least) from this link (especially if the link is external and maybe in future doesn't exist at all). – NickTux Feb 15 '14 at 16:43
  • I dont believe this. Was searching for a solution for days. Thank you Is there already a permanent solution ?? – user266751 Apr 8 '14 at 16:30
0

Installing gnome classic shell worked for me and fixed these issues very effectively; I couldn't use Ubuntu prior to it.

sudo apt-get install gnome-shell
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.