My system is using the Ambiance theme in Ubuntu Natty. Everything works correctly except for Nautilus, which appears to have been deprived from its theme. Grey nautilus doesn't look healthy

Can anyone help me restore it to the default Ambiance theme? (I've tried setting other themes but Nautilus is still grey)

If I open Nautilus with 'sudo' from the terminal, this bug isn't present and the theme is shown correctly.

I thought the Desktop forgets theme? answer would solve my problem, but after restarting, the theme-less Nautilus is back.

Something I noticed is that this problem is present in Nautilus and with Nautilus only. As I said, if I run Nautilus as root the problem isn't present, only when running Nautilus as a normal user


Well, after searching around. Adding a delay to gnome-settings-daemon when logging in corrected the problem


Can you change your icons theme?


1) Hit Alt+F2 and paste gnome-appearance-properties

2) Go to "Theme" and click "Customize".

enter image description here

3) Go to "Icons" and choose one.

enter image description here

  • I just tried, I can change the icons but nautilus is still theme-less. Please see my update
    – bruno077
    May 1 '11 at 19:56

change the theme as root and put the themes you want in root.. this works for me..

in otherwords become root and bring up your customization and select your theme or just download ubuntu tweak and have it fix the root theme bug


There's definitely some kind of configuration issue going on. Currently it seems like root and your login have different settings for themes.

Try running gksu gnome-appearance-properties

If you already see your default theme in there, and it isn't selected, all you need to do is select it.

if you don't see your theme in there, it will explain why root defaults to another theme. Then you should check if your default theme is install at /usr/share/themes/ or simply install them again to that location.

if it's there and it's already selected, or selecting it doesn't make a difference, then still check your /usr/share/themes/ folder to see if the files are missing or broken or have wrong permissions.... hope this helps.


yeah that fixed it for me

mv ~/.gconf/apps/nautilus ~/.gconf/apps/nautilus.old && killall nautilus

..if it helps the last time I remember it was ok was the day before I 'discovered' dconf, so assume I broke it with that - or it was a coincidence.


I found great solution here:

rm -vr ~/.gconf/apps/nautilus && killall nautilus

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.