Install Ubuntu 12.04.3 LTS alongside Win8 (hardware is i5 processor with SSD memory with touch screen - sony vaio ultrabook)

Got Ubuntu 12.04.3 installed successfully. Shared below successful steps followed to get Ubuntu 12.04.3 finally working:

  • USB ubuntu image created
    I had another laptop running ubuntu 10.04. So created 12.04.3 ubuntu image using 'Startup Disk Creator' from within ubuntu. USB Disk image created from windows may work, but at least i couldn't make it work.
  • Disabled fast boot in Win8.
    You can access it from Win8 Control panel --> Power Options
    --> select the check-box 'Choose what the power options do'
    --> select the check box 'Change settings that are currently unavailable' at the top of the screen to enable the option to choose
    --> Now the setting gets unlocked. Un-tick the checkbox 'Turn on fast startup' and then reboot.
  • Disable UEFI secure boot
    Inside BIOS setting, under 'Security' tab, disabled the UEFI secure boot.
  • Regarding Intel SRT option
    Somewhere in ubuntu forum, i read to disable Intel SRT technology option, but at least i didn't have to do any changes regarding this option. May be not required for my Sony Vaio Ultrabook.
  • Removed all other usb devices plugged in for eg: usb mouse.
    In fact, I had my usb disk image plugged into USB 3.0 port.
    Before , getting it successfully, I saw this error message often: “unable to find a medium containing a live file system”.
  • Wireless on ubuntu
    Recommend not to try to turn on Wireless if your wireless SSID is not shown by default.
    Now even after, installation is complete, if you can't connect to wireless, then its possibly because of the acer-wmi module. I did something similar to what is mentioned in this link:
    [broadcom 43225 wireless on acer laptop is disabled

Nothing additional done to enable touch screen. By default, working after ubuntu installed.

Unsolved pending issue: However, upon reboot into Win8, have some errors - "error: invalid EFI file path".

Any brief answer to solve this would be appreciated.
Thanks folks !


Try using my rEFInd; I've seen several reports that it will fix this problem. You can try the USB flash drive or CD-R version risk-free, then install the Debian-package version if that works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.