I have had a single Ubuntu virtual machine that I have upgrade over the years. It literally has nothing on it except a couple files. I recently decide to upgrade it from I believe 13.04 but I could be mistaken.

A picture is worth a thousand words. How do I reinstall launchpad ( is that what its called ) so regain some sort of control over my virtual machine? I was forced to uninstall Nvidia's drivers because it was booting and my mouse was a X icon.

Before I "installed" 13.10 the virtual machine was working. I have pressed the "Windows Key" and it does nothing. The host machine is Windows x64. The virtual machine itself is a VMWare virtual machine.

If somebody has a better name for the title of this question I am open to suggestions.


In an attempt to "reset" Unity I was able to determine that compiz ( no idea what this is ) was unable to find the opengl plugin

enter image description here


2 Answers 2


I was able to resolve my problem by running the following command.

sudo apt-get install --reinstall compiz compiz-core compiz-gnome compiz-plugins-default compiz-plugins-main-default compizconfig-backend-gconf

I then installed dconf-tools

sudo apt-get install dconf-tools

Since I was using 13.04/13.10 I ran the following command

dconf reset -f /org/compiz/

The last command duplicates the function of


As you can see everything is back:

enter image description here

I was forced to reset the virtual machine ( i.e. hard boot ) in order to get Unity. The terminal window I had stop responding. I had actually had a text editor window open and wasn't able to close that either.


This seems very strange indeed, running a virtual machine uses the VMware graphics and other drivers available to the host system and shouldn't ask you to install nvidia's own driver for the virtual system... Since you only have a few files I'd copy those to a safe place and do a brand new installation of Ubuntu 13.10 on the virtual system taking care to mark all partitions for formatting... This should fix any problem...

  • The problem was connected to compiz. I ran a couple command ( need to determine what they were ) and ran a different command to "restart" unity and everything came back. Installing the Nvidia drivers never caused me a problem before.
    – Ramhound
    Dec 8, 2013 at 8:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.