1

So I know this is a problem that has been asked around a lot, but I've tried a bunch of solutions with no success. I'm running Ubuntu 12.04 (64 bit), and I just installed it yesterday. This is my first time working with linux.

The error is: You are missing the following 32-bit libraries, and Steam may not run: libc.so.6

Things I've tried. First, I had downloaded from the steam website. I uninstalled it, and tried again from the ubuntu software centre.

sudo apt-get update
sudo apt-get install ia32-libs
sudo apt-get upgrade

This installed a bunch of the 32 bit libraries, but did not fix the issue. This seems like the major fix for most people. The direct approach of

sudo apt-get install libc.so.6

returns this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libc.so.6
E: Couldn't find any package by regex 'libc.so.6'

I guess libc.so.6 isn't a package, just a single file or something? I also tried

gksudo gedit /etc/ld.so.conf.d/steam.conf

Added these two lines, those the second one was all ready in the file, but copied over:

/usr/lib32
/usr/lib/i386-linux-gnu/mesa

Then executed:

sudo ldconfig

But nothing seemed to happen, steam still doesn't work.

So, I feel like it is more likely that I have the library and steam isn't looking in the right place. One thing I've seen is people usually reference /usr/local/lib/ for your library locations. However, I can't find where to cd into /usr/, it isn't in my home folder. If /usr/ is the home folder, there is only a /.local folder which only has /share, no lib anywhere. Sorry for my linux ignorance.

I appreciate any help, I honestly have no idea how to confirm I have the library and point steam to it, or if that is even the right thing to do.

Edit: Tried this, not entirely sure what it means

~$ ls -l /lib32/libc*
-rwxr-xr-x 1 root root 1721832 Sep 30 11:06 /lib32/libc-2.15.so
-rw-r--r-- 1 root root  185928 Sep 30 11:06 /lib32/libcidn-2.15.so
lrwxrwxrwx 1 root root      15 Sep 30 11:06 /lib32/libcidn.so.1 -> libcidn-2.15.so
-rw-r--r-- 1 root root   34316 Sep 30 11:06 /lib32/libcrypt-2.15.so
lrwxrwxrwx 1 root root      16 Sep 30 11:06 /lib32/libcrypt.so.1 -> libcrypt-2.15.so
lrwxrwxrwx 1 root root      12 Sep 30 11:06 /lib32/libc.so.6 -> libc-2.15.so

marked as duplicate by Eric Carvalho, David Foerster, Charles Green, Evandro Silva, muru Jan 19 '16 at 20:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Steam is installable via apt-get at least on Trusty - and it works fine. – RobotHumans Dec 7 '13 at 21:15
  • 1
    Have you tried sudo apt-get install libc6-i386? – Balgerda Dec 7 '13 at 21:18
  • I meant libc6:i386. – Balgerda Dec 7 '13 at 21:41
  • Yes Balgerda, I've tried that and it doesn't install anything new. Which I presume means I have the libraries needed, steam just can't find them. – M_Steam_User Dec 7 '13 at 21:49
  • LD_PRELOAD=/lib32/libc.so.6 steam but this gives me wrong ELF class: ELFCLASS32 – PvdL Dec 14 '15 at 12:11
0

Can you try this command:

sudo dpkg --add-architecture i386

then retry these commands:

sudo apt-get update
sudo apt-get install ia32-libs
sudo apt-get upgrade

Also, you can try

sudo apt-get install libc-bin:i386
-1

I had the same problem with Steam, and I tried this command for an other problem with my webcam:

sudo apt-get install linux-generic-lts-raring

I had to restart my computer and after this, it worked! I think it was a problem with the kernel, I don't really know what it is, but thanks to the ubuntu coommunity.

  • Raring Ringtail ended support few days after this answer was given. It might have lead to a solution when Raring was supported. Now it is in any case irrelevant and should not mislead new readers that come here looking for solutions. – Zilvador Jul 28 '15 at 8:13
-4
sudo apt-get install curl 
sudo apt-get install jockey-common
  • 1
    Can you add more information? – Seth Dec 11 '13 at 2:32
  • 2
    I don't see how this answer is related to missing i386 libraries for Steam. – David Foerster Dec 11 '13 at 11:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.