I recently installed Ubuntu alongside Windows 8. Then used Boot Repair and all was fine.The Grub boot loader showed-up and had an option to boot Ubuntu or Windows. Then I booted into windows. Everything looked fine until I rebooted. After I rebooted there was just a black screen with some text saying:

No boot device available 
SATA 0: Installed 
SATA 1: Installed 
SATA 2: None
SATA 3: None
Strike the F1 key to retry boot, F2 to run setup utility

When I hit the F2 key it takes me to the BIOS setup where i see that it is trying to use the Windows Boot Manager instead of the Ubuntu Boot Manager.

I am not sure what i can do here, if it is of any use i do have both a Ubuntu installation disk and a Windows installation disk. Oh and the Bootinfo link from running Boot Repair is http://paste.ubuntu.com/6536548/

Thanks in advance for your help.


Run Boot-Repair, but when asked "Do you want to activate [Backup and rename Windows EFI files]?", answer No. Then in your BIOS (UEFI firmware), set Ubuntu as default entry.

Now using Windows should not mess up the boot any more.

  • So i will have to re-install Ubuntu so i can get to a terminal, and then run the Boot Repair command. – Isaac Dec 8 '13 at 23:49
  • No, you just need to run Boot-repair from a live disk. See help.ubuntu.com/community/Boot-Repair#Getting_Boot-Repair – LovinBuntu Dec 9 '13 at 1:07
  • I tried that, and it sort-of worked... Windows Boot Manager is still the only entry in the BIOS, but it works now. – Isaac Dec 12 '13 at 20:28
  • Forgot to mention the Boot Info link. Here it is. – Isaac Dec 12 '13 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.