0

I added the input method "Chinese (Pinyin)" in "Text Entry Settings" while using Unity. However, when I now login with "GNOME Flashback" or "GNOME with Xmonad", "Chinese (Pinyin)" does no longer show up in the list of "Input sources to use". Also, it is not available in the list "Select an input source to add".

When I log back into Unity, "Chinese (Pinyin)" appears again as if it had never been gone.

Why is that?

(I can still switch between "English (US)" and "Chinese (Pinyin)" when not logged into Unity. However, the little overlay that shows the input candidates is missing when not using Unity, making Pinyin input useless. This issue may or may not be related.)

  • 1
    Close voters, this is not OT, but a legitimate issue about how to workaround the different ways Unity and Gnome Flashback handle input switching. – chaskes May 21 '14 at 3:53
0

The basic issue comes from the different ways that Unity and Gnome Flashback integrate input methods with Unity using Text Entry settings and ignoring ibus-setup, while Gnome Flashback still uses ibus-setup.

First let me say that I'm using 14.04. In Unity, I can add pinyin through Text Entry. When I login with Gnome Flashback, pinyin is indeed not available from Text Entry as you say. But input method switching from the menubar indicator still shows pinyin and pinyin entry works fine.

If this is not the case for you in 13.10, you can add pinyin entry from Gnome Flashback, but it works a little differently.

Don't use Text Entry. Rather, use ibus-setup in a terminal (the gui looks a little different that it used to, by the way).

Go to the Input Method tab, click Select an Input Method, and scroll down to Show All Input Methods. You may need to click Select an Input Method again, but this time when you scroll down, you will see Chinese. When you highlight Chinese, pinyin and other input methods (depending on what you have installed) will popup on the right; but pinyin should be there by default. Choose the one you want.

In 13.10, integration of input switching into Text Entry and the use of the new version of ibus-setup was still something of a work in progress; so it's possible that you are experiencing a bug. But either following the above method with ibus-setup in Gnome Flashback or upgrading to 14.04 should provide a workaround for you.

  • Thanks for the explanation. I've also switched to 14.04 in the meantime. I still had to log into Unity once to add Chinese input, but that's not too much trouble. (More importantly, the overlay issue mentioned in passing is fixed.) I also tried out ibus-setup, but changing anything there doesn't seem to have any effect. – ke. May 21 '14 at 21:43
  • I'm glad it worked out. ibus-setup has no effect in Unity, but is still needed if setting up initially from gnome flashback. – chaskes May 21 '14 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.