Using Lenovo B590 my max res in Displays is currently 1366x768. im trying to change it to 1600x900.

i tried following this guide: https://wiki.ubuntu.com/X/Config/Resolution#Adding_undetected_resolutions

but something goes wrong, first i did xrandr - this is my output:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 32767 x 32767 LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm 1366x768 60.0*+ 1360x768 59.8
60.0 1024x768 60.0 800x600 60.3 56.2 640x480 59.9 VGA1 disconnected (normal left inverted right x axis y axis) HDMI1 disconnected (normal left inverted right x axis y axis) DP1 disconnected (normal left inverted right x axis y axis)
1600x900_60.00 (0xcc) 118.2MHz h: width 1600 start 1696 end 1856 total 2112 skew 0 clock 56.0KHz v: height 900 start 903 end 908 total 934 clock 59.9Hz

after that xrandr --output LVDS1 --mode 1600x900 told me it cannot find the mode so i tried adding it.

input cvt 1600 900 60 got:

1600x900 59.95 Hz (CVT 1.44M9) hsync: 55.99 kHz; pclk: 118.25 MHz
Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync

now as par the guide i copied everything after Modline and put it in newmode like this:

xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync

got this:

X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  29
  Current serial number in output stream:  29

and that is where im stuck because now

xrandr --addmode LVDS1 1600x900

still cannot find mod.

thank you

  • according to this page your laptop should have a 1366 x 768 screen. why do you want to set the resolution higher than that? – Wouter Dec 8 '13 at 10:55
  • well reason is its REALLY big for my eyes, im used to 1980x1200 on my desktop and i wanted to force higher res to enjoy more space (well, same space but used better) – Giladiald Dec 9 '13 at 14:25
  • 1
    Isn't what you really want to do than changing the DPI settings (dots per inch) I don't have experience with that but this question talks about that. – Wouter Dec 9 '13 at 16:06
up vote 0 down vote accepted

This is not much of an answer, but it can work (sometimes) - I have not tried this for a while...

Set it up so it is at the default 1366x768, then reboot.

Then at the login screen, enter tty - Ctrl+Alt+F2 - and login as your user via that.

Edit ~/.config/monitors.xml by running nano ~/.config/monitors.xml - edit this:

      <width>1366</width>
      <height>768</height>

to be:

      <width>1600</width>
      <height>900</height>

Press Ctrl+O then , and then Ctrl+X to exit the editor.

You can then exit tty by running exit, and pressing Ctrl+Alt+F7

Login, it should work... ~/.config/monitors.xml seems to be where the Display settings saves configuration...

  • thank you for giving it a try - when i do that and log in i get a big white note saying "Could not apply the stored configuration for monitors" with tons of text, and it stays on the same res as before, file is being edited back automatically as well. – Giladiald Dec 7 '13 at 13:19
  • Don't know then... – Wilf Dec 7 '13 at 13:28

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.