2

I'm using a Lenovo SL500 for several years now and suddenly the Volume keys stopped working. It could be that a kernel updated caused it - I don't know.

However when I go to the keyboard settings -> Shortcuts -> Sound and Media, I can set e.g. Volume Mute with my multimedia key and then it says "AudioMute". But when I later hit the Volume Mute key nothing happens.

4

I found a solution: deleting ~/.pulse then logout. Next time it happens I will try the other answer too.

  • 2
    This has fixed my problem, but you must reboot the computer, not just logout, or you may find all the sound controls to be quite broken. I recommending taking a backup of .pulse incase you need to revert. – Steve May 30 '14 at 8:40
  • This is the right answer, helped me too. – Piotr Jurkiewicz Sep 20 '14 at 0:40
  • Deleted folder and rebooted. This helped in my case as well (Asus N55S). It restored the sound previously gone from the left headphone channel and the volume and mute keys. Thanks! – Andrea Borga Dec 2 '14 at 22:03
  • I just killed pulse-audio instead of logging out, it worked – vanjoe May 5 '15 at 20:33
2

I had the same issue on 15.04

There was no .pulse but there was .pulse-cookie. So I deleted it and it works like a charm now.

So updated solution for 15.04:

sudo rm ~/.pulse-cookie
  • This also works on ubuntu 12.04. Thank you so much! – laughing_man Aug 1 '16 at 2:59
1

Resetting media key prefrences worked for me

dconf reset -f /org/gnome/settings- daemon/plugins/media-keys/

if it does not work maybe you should try

dconf reset -f /org/gnome/settings- daemon/plugins

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.