I just built a computer with two sapphire HD7950 graphics cards. I've tried installing both lubuntu and xubuntu (for scrypt mining) and in both cases the same thing happens. After the initial splash screen that just shows the logo and a loading thing, it goes to a black screen with a cursor.

If I CTRL+ALT F4 for example, it brings me to a xubuntu@xubuntu terminal window. I wouldn't mind that much only having a terminal, but I'd like to know how to get the GUI back.


EDIT: I have also tried with lubuntu the "nomodeset", which just displays a whole bunch of errors, most of them say SQUASHFS error: Unable to read data cache entry

  • 1
    Same problem here. Thought it maybe had something to do with my card. Going to mine on windows now :(.. Some info: Cards 2x R9 280X - Mobo: Asrock 990FX Extreme4 - Other distro's I tried: Ubuntu Server 12.04 TLS (success), but you need X for mining, so installed ubuntu-desktop after. Was never able to boot successfully in the desktop (could connect with ssh and install it), but maybe I gave up too soon on this approach. Ubuntu-desktop 13.10 and 13.04, same problem as Xubuntu. – Luigi van der Pal Dec 14 '13 at 15:12
  • Are you trying to boot to a Live session to install, or have you already installed Ubuntu? Check out askubuntu.com/questions/162075/… – Richard Dec 15 '13 at 12:58
  • Is this first boot after install, before activating the ATI/AMD drivers, or after activating drivers for the cards? – grinch Dec 15 '13 at 13:19
  • did you try booting with an older card first and only that older card.. and then adding one HD7950 (but not using it yet to display video) and then at least you have eyes (the older card) to see if you can install/troubleshoot drivers etc etc.. and then when that is figured out shutdown swap the old card with the other 7950 and work your way from there etc etc.. this is what i would do.. – marc-andre benoit Dec 21 '13 at 4:50
  • Just wanted to say thanx same exact problem with my rig. Fix worked like a charm! – user293714 Jun 15 '14 at 9:01

Other distros had at same time this same problem, despite of installation-CD or DVD ... apparently it was forgotten to include the package of xserver-xorg in the installation-process.

If protected-mode is possible, you could try to install xserver-xorg by running the following command:

sudo apt-get install xserver-xorg*

After this, run the following commands in protected mode (Strg + Alt + F1) and install the graphics-drivers suiting to your graphics card.

sudo apt-get install fglrx-updates fglrx-amdcccle-updates fglrx-updates-dev
sudo aticonfig --lsa
sudo aticonfig --adapter=all --initial
sudo reboot

After reboot is finished, run the following command in protected mode too with (Strg + Alt + F1):

sudo aticonfig --adapter=all --odgt

Now it should work...


I tried what dschinn1001 said but that didn't work for me. What did work for me was going into nomodeset mode.

In Xubuntu this is done at the options menu, select "Try Xubuntu Without Installing" press Tab and add nomodeset to the very end of the line. Press Enter and it will load right up. Then you can start the install from there.

In Ubuntu at the GRUB menu you press e to edit the line. Look for the linux entry and add nomodeset to the end of that line. Then press F10 to boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.