4

I'm trying to change Indicator Synapse keyboard shortcut using dconf-editor.

net -> launchpad -> synapse-project -> indicator 

On shortcut i set

<Control>space

but nothing changes.

Notice that event the default keybind is not working (Super Alt space)

I am using ubuntu 13.10

Any ideas?

  • I am using 14.04 and none of keybinding is working. – serdar May 25 '14 at 18:29
  • 1
    Alt + F10 -> Works... Maybe you will need another F-Function Key, like f11 or f12. Just try. – Diego Garcia Vieira Jun 7 '14 at 13:32
  • @DiegoGarciaVieira Alt+F10 works, thanks. Any chance i can change it? – Simion Agavriloaei Jun 8 '14 at 19:30
2

This is a known issue Shortcut to activate synapse resets to Control-space every reboot and still pending. If you feel up to it, there is a patch.

Even if the shortcut is correctly saved in $HOME/.config/synapse/config.json, it won't works.

  • Synapse that mentioned in this question is actually indicator-synapse. It is like spotlight at Mac for linux, not like gnome do or launchy. – serdar May 25 '14 at 18:28
2

There is a work around for this, using xdotool. This tool lets you simulate keyboard input and mouse activity, move and resize windows, etc. It does this using X11's XTEST extension and other Xlib functions.

Here, we are going to find the coordinates of the mouse, and emulate a mouse click on the synapse indicator using a command and set a shortcut key for the command.

Step 1: Install xdotool.

sudo apt-get install xdotool

Step 2: Move your mouse over the synapse icon and get mouse location

xdotool getmouselocation

You should get output like this:

x:1105 y:14 screen:0 window:39845936

Step 3: Add keyboard shortcut for indicator

Go to System Settings -> Keyboard -> Shortcuts -> Custom Shortcuts.

Click the + and enter the below command:

xdotool mousemove x y click 1 mousemove restore

Replace x and y with the values you got. Set the shortcut as Ctrl + Space Logout and Login again.

Voilà!

1

I installed in Ubuntu 16.04.3, by the time I install ubuntu already had the ppa, so I simply installed by

sudo apt-get install synapse

The default shortcut was ctrl + space, only flaw was, settings (synapse) did not work.

Since I was using ctrl + space for some other purpose, I wanted to change it to alt + ctrl + space. I simply fixed it with a custom keyboard shortcut.

Go to custom shortcuts Setting -> Keyboard -> Shortcuts -> Custom Shortcuts. Click on +, give a name (Synapse) and command (synapse), then Add. That's it now you I can use my custom shortcut.

enter image description here

0

This could be a conflict with what you're telling ubuntu to do globally and what Synapse is trying to do with its own shortcut assignment. I would recommend trying to set the shortcut from within Synapse: click the dot on the right side of the search pop-up, open the preferences, and you can set the shortcuts there.

-2

It's Ctrl+Space. I just tried it and it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.