On my Asus F201E with Ubuntu 13.10, I have used headphones without problems until a few days ago, I opened Clementine and Audacity at the same time, and now my headphone port does not work anymore. I am not sure if those two apps are related to the issue, but this is the only thing I can think of.

Reading other similar questions around AskUbuntu (about 8 of them), I could not find a solution that would work for me.

The problem is not related to the headphones (same issue with three sets), and the internal speakers of the laptop work fine. The headphones are still recognised as the speakers are muted when the headphones are plugged. The issue is not a hardware issue as I could boot into a usb startup disk with 13.10 and use headphones without any problems.

When a sound is supposed to be sent to the headphones (music, or sound when changing the sound level for example), I only get a little "breathing" sound or a crackle. I played with the sound settings to no avail (changing the output manually), as well as alsamixer. I also tried reinstalling (and purging) the following packages:

  • alsa-base
  • pulseaudio
  • indicator-sound

But nothing changed. I also tried editing the following files:

  • /etc/modprobe.d/alsa-base.conf
  • /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

as suggested in that question, but still no results.

I am sure I could reinstall the whole system but I have so many apps, ppa, configuration files and documents everywhere that I would rather find a smaller fix.

I was wondering if you had any idea of other packages I could try to uninstall ; purge ; reinstall? Or any other idea?


Update: I edited this as I now figured out that it is Audacity's problem. Every time I try to use it, my headphone port stops working straight away, and even when Audacity is closed, I can not use anything else with my headphones. It takes a few days before the problem fixes itself somehow.

5 Answers 5


I found a workaround that I described in the bug report mentioned in the other answer (bug 1257956, related to bug 1018262).

I went into Audacity and changed the microphone source in the drop-down menu from "sysdefault: Headphone Mic:0" to "sysdefault: Internal Mic:0" and it fixed it. I can now use my headphones, even when I restart Audacity.

  • I can't believe this still happened to me in 2020, and this solution helped Apr 6, 2020 at 21:30

It is apparently a bug with Audacity 2.0.3 to 2.0.5, it messes up Alsa, as described on Launchpad. I haven't found any way to repair this, except reinstalling and not using Audacity.

According to some Google searches, you could maybe bypass that bug using OSS instead of Pulseaudio, or try an older version of Audacity, but I haven't tried it, I'm tired of reinstalling Ubuntu (once with 2.0.3 and once with 2.0.5)

  • Yes, I found out about that bug a few days ago and didn't get around to mention it here.
    – stragu
    Mar 24, 2014 at 4:59

I ran into this same problem with the 2.1.2 version of Audacity that comes with Ubuntu. I installed Audacity 2.2.0 from


and now my headphones work again.


Changing the input source from sysdefault: Headphone Mic:0 to sysdefault: Internal Mic:0 prevents the problem from occurring again.

To fix the problem once it has occurred, try disabling and re-enabling your microphone (using the mute button) in your sound settings.

At least with my desktop environment (Gnome), the headphone jack starts working again once I do that.


I had the same problem.

After starting Audacity I executed

alsactl init

which enabled the sound for my headphones.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.