0

I recently upgraded to 13.10, and my R plugin for gedit is no longer working.

When I go to gedit->preferences->plugins and try to enable "R integration", I have little red error symbol and a message that says "An error occured: plugin loader "python" was not found"

The contents of the RCtrl.plugin file at user/lib/gedit/plugins is as follows:

[Plugin]
Loader=python
Module=RCtrl
IAge=3
Name=R integration
Description=Allows R to be controlled from Gedit
Authors=Dan Dediu <ddediu@gmail.com>
Copyright=Copyright © 2009-2011 Dan Dediu <ddediu@gmail.com>
Website=http://sourceforge.net/projects/rgedit

I did whereis python and then changed the loader=python line to read Loader=path/to/python3.3, which is what I found.

I don't know what to do at this point; would appreciate help.

EDIT: I have also tried downloading the tar.bz2 file from the developer's webpage and extracting it into the plugins folder. still doesn't work!

1

Problem solved by uninstalling the existing plugin using apt-get or Software Center and then installing the plugin from http://sourceforge.net/projects/rgedit/files/rgedit-0.8.0.2-Gtk3-Python3.tar.bz2/download into ~/.local/share/gedit. Basically just download the archive, extract, and copy thie files into the plugin directory from the archive directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.