0

I just intalled ubuntu(the real one) and now i am unable to run on my previous win7. As far as i know I didn't overwrite the windows partition. If I try to launch windows it breaks down directly(with safe mode too). Windows isn't able to start (I even lost access to the f11 menu) and asks me to insert a boot device (which I do not have sine it was pre-installed).

I followed some tipps and installed boot_repair which gives the following output http://paste.ubuntu.com/6525891/ (some EFI detected). Altough I am a newbie I presume the error is coming from the ubuntu booter.

I am completely lost so thank you for any help :)

  • oh and I do not have any dvd nearby for the moment... – user2351468 Dec 5 '13 at 18:15
  • what did you selected in Installation type?? – Sukupa91 Dec 6 '13 at 17:11
  • Since you have two drives, you must use the 64 bit version and install Ubuntu in UEFI mode on second drive to easily dual boot. UEFI & BIOS boot are not really compatible and once you start to boot in one mode you cannot switch. So that is the efi error you are now getting is Ubuntu in BIOS mode cannot chain load to boot Windows in UEFI mode. You will need to use Something Else or manual mode to correctly install to sdb. – oldfred Dec 6 '13 at 18:21
1

Before proceeding to any further make sure the Ubuntu System Architecture you are trying to use is supported by you processor then,

Try Boot-repair to repair you grub , for doing so you have to boot ubuntu live usb or dvd and after booting click on try-ubuntu.

When desktop screen appears press Ctrl+Alt+t for opening terminal and run the follwing commands into the terminal -

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)

After that the boot-repair window will appear ,in that select Recommended repair option . After completion restart your pc .it will be fixed. If you need assistance clcik on the link mentioned in first line.

hope it will work.

0

Your description of the Windows boot failure is quite vague, so it's not clear if the problem is in GRUB's handoff to the Windows boot loader (which should be fixable in Linux) or in some subsequent Windows-specific step (which would require fixing using a Windows recovery disc). If the former, you might try a USB flash drive or CD-R of my rEFInd boot manager. (One caveat: You'll need to either disable Secure Boot or jump through extra hoops to get rEFInd to boot with Secure Boot active.) If rEFInd can get both Windows and Linux to launch, you can install its Debian-package version in Ubuntu. rEFInd will then take over from GRUB as your primary boot manager.


EDIT: The boot configuration data (BCD) is data that the Microsoft boot loader uses to help with the boot process. I'm foggy on the details, but you can think of it as being roughly analogous to GRUB's configuration file, grub.cfg. Thus, your error message definitely indicates that the problem is on the Windows end -- although it's entirely possible that the file was accidentally deleted or damaged by Linux. I recommend you try using a Windows recovery disc (I have no URLs; try Googling for one, but be cautious -- something from some random Web site might be malware!) or post on a Windows forum for advice.

One more comment: There's a chance that the problem was caused by the Windows 8 (if that's what you're running) Fast Startup feature, which turns a shutdown into a suspend-to-disk operation. This means, among other things, that filesystems (including the ESP's FAT) are not properly shut down, so that when they're accessed from Linux, they can be damaged; and when you reboot into Windows, it will be confused by the changes made by Linux. Thus, it's critical that you disable Fast Startup. Various Web pages describe how to do this, like this one. Note that the Windows Fast Startup feature is completely different from any "fast boot" or "fast startup" feature you might set or disable in the firmware, so don't think that you've dealt with the issue by adjusting your firmware.

  • the exact message I get just after selecting the windows boot mode (with grub) is: An error occurred while attempting to read boot configuration data. Plus it is impossible I overwrote the partition since the secure mode (which also doesn't work) is locate on another drive. – user2351468 Dec 6 '13 at 7:11
  • But the error message definitely came from the windows-part altough I think the cause is grub. – user2351468 Dec 6 '13 at 9:52
  • Please see the edit to my original answer. – Rod Smith Dec 6 '13 at 18:07
-1

The origin of the error was way more simple... The installation disk my friend gave me turned out to be actually a 32 bit version. Therefore gnud was 32bits too and unable to run 64bits windows7. One used Bios and the ohter UEFI (as a previous comment explains).

I reinstalled the 64-version and everything works fine.

I am very sorry for having asked while the answer was right in front of my eyes :) Thank you anyway for trying to help me.

It is a real pleasure to see pople offering help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.