Whenever I open a .sh file, it opens it in gedit instead of the terminal. I can't find any option similar to Right ClickOpen WithOther Application...Terminal.

How do I open this file in the terminal?

  • Does that script aim to set up env variables for further use?
    – Rob
    May 1, 2011 at 10:47
  • 3
    You shouldn't use extensions on scripts. At some point in the future, you may find that a different language is more suitable to do the task your current script is doing. And then you have a problem. Do you keep the old name, with a completely misleading extension, or do you rename it, possibly having to edit alot of places where your script is used?
    – geirha
    May 1, 2011 at 14:07
  • You don't need the file extension. It's nice to have but is not needed. The OS doesn't look at the file extension. It looks at the data May 4, 2011 at 17:41
  • 8
    Meh, if you rewrite foo.sh in ruby, you can always use the .sh file to launch ruby foo.rb Jun 11, 2013 at 1:24
  • In Dolphin you can press F4 and a console opens
    – Motte001
    Jun 16, 2016 at 16:47

17 Answers 17


Give execute permission to your script:

chmod +x /path/to/yourscript.sh

And to run your script:


Since . refers to the current directory: if yourscript.sh is in the current directory, you can simplify this to:

  • 114
    If you do bash /path/to/yourscript.sh then you don't need chmod +x May 1, 2011 at 4:51
  • 6
    Actually, you can use . /path/to/yourscript.sh if the script have to set up some environment variables.
    – Rob
    May 1, 2011 at 10:46
  • 2
    Nobody mentions the traditional: ./path/to/yourscript.sh (without the space after .)? I find that one is the simplest and easiest to use... But anyways, here is my alternative that should do almost the same as ./ would, though I don't see why you wouldn't use ./: (FILENAME=~/rem4space.sh;SLL=$(cat $FILENAME|head -1|sed 's:^#!\(.*\):\1:g');[ ! -z $SLL ] && exec $SLL $FILENAME;sh $FILENAME) ... edit FILENAME to your liking. Also note that sh will be used if there is no alternative.
    – MiJyn
    Jun 19, 2013 at 3:50
  • It required using sudo bash on GitHub workspaces Dec 22, 2023 at 2:27

You need to mark shell scripts as executable to run them from the file manager:

  1. Right click on your .sh file and select Properties:

    enter image description here

  2. In the Permissions tab, check Allow executing file as program:

    enter image description here

  3. Close the Properties window and double-click the file. A dialog will pop up giving you the option to run the script in a terminal:

    enter image description here

  • 12
    This isn't working in Ubuntu 13.04. Keeps opening in gedit anyway, never asks me to execute. Edit: Nvm, imjustmatthew answers this.
    – mpen
    Jul 12, 2013 at 16:27
  • Before using this we need to make the file permission for execute using chmod. chmod +x filename.sh or chmod 755 filename.sh Mar 16, 2017 at 15:11
  • I don't have popup! IDE is opened straight away, not a popup
    – Green
    Apr 4, 2018 at 10:56
  • How come I can't find "run in terminal" anywhere on my interface? (Ubuntu 18.04) May 9, 2018 at 22:08
  • 3
    @DanielMöller, here is the answer to your question. askubuntu.com/questions/38661/how-do-i-run-sh-files/… Aug 16, 2018 at 10:19

Open a terminal and navigate to the folder where the .sh file is located. Then type:

sh <name of file>.sh
  • 2
    the best way to open any application. Navigate to .sh directory then open it in command prompt. the use sh <name of file as shown above>.sh if it requires permission use chmod +x /path/to/yourscript.sh or right click and change permission to all Mar 19, 2019 at 9:23
  • This is my favored method of doing it. @DurgeshKumar nice tips.
    – wlwl2
    Jan 6, 2020 at 10:40
  • Tried to run a sh script on alpine. While other answers did not work, this did.
    – Vankog
    Oct 9, 2020 at 11:32
  • how about $ sudo bash asdad.sh Jan 7, 2021 at 18:28


Before you can run the .sh file, you need to make it executable:

  1. Right-click on the file
  2. Select Properties
  3. Select Permissions
  4. Select Allow executing file as a program


Make sure you trust the source where you got the file from. It could be a virus.

The very simple way

  1. Double-click on the file
  2. Click run in terminal

This has problem. The terminal will close immediately and you will not be able to see the output.

The simple way

  1. Open Applications -> Accessories -> Terminal
  2. Drag and drop the .sh file into the terminal and press Enter

The way professionals do it

  1. Open Applications -> Accessories -> Terminal
  2. Find where the .sh file

    • Use the ls and cd commands
    • ls will list the files and folders in the current folder. Give it a try: type "ls" and press Enter.
    • Once you see the folder that you want to go in to, run cd, followed by a space, followed by a folder name
    • If you when into a folder that you did not want, run cd .. to go one level up
  3. Run the .sh file

    • Once you can see for example script1.sh with ls run this:


Why do it the complicated way?

The terminal has a rich set of powerful tools that are accessible by typing the commands. Professionals locate the .sh file by typing ls and cd. Once you are in the correct current folder you can run the script like this:


or you can run and redirect the output to a file:

./script1.sh > out.txt

or you can filter the output for keywords (e.g. "apples") an then redirect to a file:

./script1.sh | grep apples > ./only-apples

There are thousands of things you can to to that file just by typing a few commands.

Another one, you can download a file from the Internet with one simple command:

wget www.google.com/images/logos/ps_logo2.png

And then open the file like this:

shotwell ps_logo2.png
  • 10
    Im not sure that The way professionals do it is correct, it's more a case of the simple way the advanced(for for control of output) way
    – Hailwood
    May 1, 2011 at 4:24
  • It's good to know I did it the way professionals do it on my first trial. I thought it was the basic user's way.
    – NelsonGon
    Jun 11, 2019 at 5:06

On Ubuntu 13.04 executable files opened in Nautilus are now opened in gedit by default rather than prompting the user to execute them. To enable the classic behavior you need to adjust the preferences:

Nautilus → Edit menu → Preferences → Behaviour tab → Click the radio button near Ask each time.

  • The person who asked the question is talking about Ubuntu 10.10
    – edwin
    Jun 11, 2013 at 0:48
  • 2
    Thank you!!! I don't know why they'd change this, couldn't figure out how to execute anything.
    – mpen
    Jul 12, 2013 at 16:28
  • 2
    This is the right answer for latest ubuntus.
    – gaRex
    Apr 11, 2015 at 11:44
  • How do you get to Nautilus in 15.10?
    – yaakov
    May 23, 2016 at 17:54
  • 3
    As of Ubuntu 18.04, you can access the preferences by opening a directory and then clicking "Files -> Preferences" in the top bar.
    – tparker
    Nov 17, 2018 at 20:04

For Ubuntu 18.04, There is a little modification, as you don't get a pop-up dialog.

So what you need to do is:

Right click on Files, Select Preferences > Select Behavior Tab > Mark 'Ask what to do' option under Executable text file.

Now, When you double-click on any .sh file, you will get a popup, there you can select "run in terminal" option to run your .sh file.

enter image description here

  • 2
    bit weird as I don't have the "preferences" option in right click menu. I only have properties. Sep 11, 2020 at 11:53
  • For me this also made it ask for other completely unrelated extensions which is a real drag. Anyway to only make it ask this for things ending in a .sh extension.
    – Kvothe
    Dec 3, 2020 at 16:45

Go to the directory where the .sh file is by using cd. In this example I have stored my sh file as ~/Desktop/shell_practice/test.sh

first do pwd to figure out where you are, and if it returns /home/username (where username is your real username), you can run

cd Desktop/shell/practice

If you seem to be somewhere else, you can use the absolute path

cd ~/Desktop/shell/practice


cd $HOME/Desktop/shell/practice

or even

cd /home/$USER/Desktop/shell/practice

these are all ways of describing the same place. Once you've made it to the location of your script, type


If you can see the sh file in the output, you can use chmod to make it executable. In my case, remember, the filename is test.sh, so I would run

chmod u+x test.sh

Now that we are in the same directory as the script, we have to specify to the shell that we want to execute the file by giving its location ./ (the current directory followed by a path separator, to distinguish it from the filename). To run my file I would type:


If your script has been written correctly it will run without errors...

Here's a live example: Here is live example

  • This worked for me to install Netbeans on ubuntu
    – RuD3B0y
    Jan 6, 2018 at 20:16
  • 2
    Wb, @RuD3B0y, i tried to keep the answers best for noobs, no high tech content, if you have some edits you are welcome. Apr 2, 2018 at 17:58

There are a few ways to do this.

Option 1

  1. In the terminal, access the directory the Bash file is in using cd (change directory).

    Ex. cd Downloads

  2. Run bash <filename>.sh

    This also works with .run files. There is an example of this usage at this webpage on updating Rhythmbox.

Option 2

  1. In the terminal, navigate to the directory the bash file is in.

  2. Run chmod +x <filename>.sh

  3. In Nautilus, open the file.


2 main steps.

  1. in terminal, use gedit to write and save script with ".sh" extension to desktop. (but any text editor can be used)

  2. open Nautilus and right click the script.sh file.

    • under properties, check box "allow executing file.."

    • in Nautilus menu, click file,then preferences,then behaviour

    • check the "run executable text files when they are opened".

Now, when you double click the file on the desktop, it should execute. no need for . or ./

  1. Right-click the .sh file and make it executable.

  2. Open a terminal (Ctrl+Alt+T).

  3. Drag the .sh file into the terminal window and watch in awe.

  • 2
    Welcome to Ask Ubuntu! I recommend to edit this answer to expand it with specific details about how to do the first step. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) Jun 10, 2017 at 15:49

In Ubuntu 16.04 this is how to open it in Terminal:

Go to the File Manager > Edit > Preferences > Behavior for Executable Text Files and select Ask each time.

The problem is that it's by default set to View Executable Files when they are opened.


If you place your shell script or other executable you create in /usr/local/bin it will be found and executed without having to provide a folder path in the command line or adding ./ to the name. For example I created the following simple 3 line bash script to display disk UUIDs:

echo "* UUIDs must match in /etc/fstab and /boot/grub/menu.lst"
sudo blkid

I called the file uuid and placed it in /usr/local/bin. All I need enter on the command line is:


Well, I too faced the same problem. I wanted to execute the .sh file and it opened with Gedit on CentOS 7. So here is what I did:

  1. I navigated to the path of the .sh file I wanted to execute.
  2. I opened the terminal.
  3. And I simply dragged and dropped the on the terminal window and it automatically took that file along with the path as input.
  4. Hit Enter and you are good to go!

The problem I have found on a few distributions is they have hidden the preferences option in Nautilus, but to fix it in Ubuntu and other distributions using Gnome3 is the same (literally just done the Fedora version of this and posting the actual fix to remind me how in the future).

  1. Install dconf-editor

    sudo apt-get install dconf-editor
  2. Run dconf-editor using the user account you want this on, i.e NOT root

  3. Navigate to the following schema:


  4. Change the default option to not open by default:

    Find executable-text-activation click the word display and change to ask

that will give you the option to edit, view or run the file going forward


I am a noob in Linux and I just had the same problem. If all else fails:

  1. Open terminal
  2. Open the folder containing the .sh file
  3. Drag and drop the file into the terminal window
  4. The file's path appears in terminal. Press Enter.
  5. Voila, your .sh file is run.

Finally got it figured out. On Ubuntu 22, April 2024

So, besides checking Allow executing file as program In the Permissions tab of Properties you have to rightclick your shell(sh) file and press Run as a program EACH TIME you gonna launch it !!!

Otherwise it will get opened by Text Editor or by whatever you have assigned it to be opened in third tab, namely Open with, of Properties popup before.


You can also use . tricks, with the suggestion of other answers.

For example:

chmod +x filename.sh, assuming you have already gone to the path to file then run the file with any one of these command:

sh filename.sh


. filename.sh
  • 2
    warning: These three commands are not equivalent. If your shebang references a different binary (like Stack), then the third command will try parsing arguments with Bash, which will fail. Feb 18, 2017 at 11:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .