I upgraded to 11.04 from 10.10 yesterday on a dual boot on a desktop system with Vista. Everything was acting fine until the upgrade. The upgrade appeared to be running properly and I went to do something and when I came back, the screen was black and I couldn't get any response from the PC. I reset the sytem. Here is the problem, on boot the GRUB menu appears normally(but with the 10.10 system displayed instead of 11.04) I can select the VISTA OS and the system starts normally. If I select the Ubuntu OS, I eventually get the following error:

init: udevtrigger main process (448) terminated with status 1 init: udevtrigger post-stop process (452) terminated with status 1 init: udevmonitor main process (447) killed by TERM signal

The disk drive for / is not ready or not present Continue to wait; or Press S to skip mounting or M for manual recovery"

All partitions are recognized by fsck -l. I tried to boot from a live cd of 11.04, but I keep being sent to the GRUB menu. Can someone help me get past this hiccup? It seems that GRUB didn't update and just needs to be directed where to look for linux package. I am just learning about Linux, but am willing to put some time into it. I just need some direction. Thanks!

  • I would be really interested in finding why this happened because I spent a lot of time to solve this problem (remote server). – sorin May 21 '11 at 10:49

I had a similar problem. Here's how I fixed it (what I remember at least; I was basically just following some forum posts I found, mixed with some experimenting).

  1. Press M to do a manual recovery.

  2. run mount -o remount /. IIRC / is mounted read-only, so this will remount it for writing.

  3. run dpkg --configure -a.

  4. Type Ctrl+D to exit the shell and reboot.

  5. Hopefully, it should boot fine so you can finish the upgrade. I actually don't remember exactly how I did that, sorry. I followed the instructions from the Ubuntu forums, but I can't find the post right now. I'll look for the instructions I followed or maybe someone else can answer it.

| improve this answer | |

mount -o remount doesn't work for me.
dpkg --configure -a error.

I have to run fdisk -l and manually mount all linux partitions to make it work.

| improve this answer | |

Here's a discussion that is related and might help: http://kubuntuforums.net/forums/index.php?topic=3116534.0

| improve this answer | |
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Eliah Kagan Jun 30 '12 at 5:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.