0

I am running 13.10 and installed GNOME 3.10 with the gnome3-next ppa from Team GNOME, as explained in an article on Webupd8.

How can I get back to Unity?

I did a ppa purge and now sort of have Unity back, but still have the GNOME boot screen, the font, the close button for windows on the right side. Also if I minimize an application, Xorg and the application have around 100% CPU usage.

Screenshot

I also tried sudo apt-get install unity and sudo apt-get dist-upgrade, but it's already up to date.

I have my home folder backed up with Déjà Dup, but I would like to avoid reinstalling and reconfiguring my whole system.

  • My understanding is that you got unity but on login it's still gnome session by default. You see foot icon ( like upper right) on login screen? Click there and see what choice is there. Also try dpkg-reconfigure lightdm and choose lightdm as default desktop. Cheers. – Sergiy Kolodyazhnyy Oct 7 '14 at 5:31
  • 1
    as mentioned, the problem is solved, i ended up re-installing the system. thank you though! – vaioonbuntu Oct 7 '14 at 9:33
0

Since you have already used ppa purge you could now:

sudo apt-get install --reinstall ubuntu-desktop

or this with an added --reinstall:

sudo apt-get install --reinstall unity unity-common unity-services unity-lens-* unity-scope-* unity-webapps-* gnome-control-center-unity hud libunity-core-6* libunity-misc4 libunity-webapps* appmenu-gtk appmenu-gtk3 appmenu-qt* overlay-scrollbar* activity-log-manager-control-center firefox-globalmenu thunderbird-globalmenu libufe-xidgetter0 xul-ext-unity xul-ext-webaccounts webaccounts-extension-common xul-ext-websites-integration nautilus nautilus-sendto nautilus-sendto-empathy nautilus-share activity-log-manager-common python-zeitgeist rhythmbox-plugin-zeitgeist zeitgeist zeitgeist-core zeitgeist-datahub
  • didn't solve it, i did reinstall it. thank you! – vaioonbuntu Jan 1 '14 at 4:43
0

solved by re-installation.

(blah blah blah)

0

use-

sudo apt-get install ubuntu-desktop unity

then remove what you have installed before by -

sudo add-apt-repository--remove ppa:gnome3-team/gnome3-next
sudo add-apt-repository ppa:gnome3-team/gnome3-staging
sudo apt-get purge gnome-shell
sudo apt-get purge gnome-documents gnome-contacts epiphany-browser gnome-boxes gnome-shell-extensions gnome-tweak-tool bijiben gnome-clocks
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo reboot

hope it helped you.

  • 1
    didn't solve it, i did reinstall it. thank you! – vaioonbuntu Jan 1 '14 at 4:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.