I have a laptop vaio duo 13 which has a broadcom 43241 wireless card. My problem is similar to this one Broadcom Wi-Fi Adapter not recognized .

I tried to install the driver brcmfmac(SDIO) here http://wireless.kernel.org/en/users/Drivers/brcm80211 and copied the nvram to /lib/firmware/brcm as the page tells, but this didn't work.

Most questions I searched are about br43 such as Installing Broadcom Wireless Drivers . I tried part of solution like unblock all in rfkill, put an # in front of blacklist bcm43xx, but none worked. I didn't uninstall or install any drivers such as b43-installer, b43legacy-installer, bcmwl-kernel-source (only tried b43-fwcutter) because they are not compatible with bcm43241.

Above is all information I can provide for help. Thanks.

  • Please edit your question to add any further information you can find about the device from: sudo lshw or: dmesg | grep -i 14e4 – chili555 Dec 5 '13 at 14:21
  • thanks for suggestion. I think it's just because the wireless card is too new for the current kernel. @chili555 – 200gaga Dec 6 '13 at 10:37
  • It would be very nice for you to share the solution so others can get theirs working as well. Can we post the bin and txt files somewhere? – chili555 Dec 7 '13 at 13:07
  • thanks for suggestion. I upload this to dropbox and post the link here @chili555 – 200gaga Dec 8 '13 at 3:15
  • 2
    Do not put your answer in your question. Use the filed below to add your answer, also don't add SOLVED tag in your question. Accept the answer that solved your problem. this is not a forum.THIS IS SPARTA! – Alvar Dec 10 '13 at 12:22

Found in the question, written by the OP.

After contacted a developer of broadcom, he gave me mails between him and an user who had same issue but have successfully solved this. The user helped me by sending another nvram and firmware (a bin and a txt) and it worked. I think it's just because the wireless card is too new for the current kernel (correct me if I say something wrong as a novice of linux).

I attach them here


copy them to /lib/firmware/brcm and execute sudo modprobe brcmfmac-sdio, the problem solved.


I tried the answer given above with no success, however I did find a working solution over in another thread and though I'd link it here for future searchers.

You need to save the below file with the SAME NAME to your /lib/firmware/brcm folder and reboot. https://github.com/jfwells/linux-asus-t100ta/blob/master/nvram/lib/firmware/brcm/brcmfmac43241b4-sdio.txt

Sony Vaio Duo 13 + Working WiFi fantastic!

Solution Credit > https://askubuntu.com/a/465349/240658

Not the answer you're looking for? Browse other questions tagged or ask your own question.