4

I just installed Unity Tweak Tool but haven't been able to use it due to the error it keeps giving, which is: com.canonical.notify-osd

I tried looking it up but haven't come up with anything so far. How can I fix this issue?

7

Go to a terminal by pressing Ctrl+Alt+T and type the following commands:

sudo apt-get install --reinstall notify-osd
sudo apt-get install --reinstall overlay-scrollbar

This will install 2 packages if you don't have them or re-install them if already present and broken.

| improve this answer | |
5

use Synaptics and search for notify-osd .Install it .

Your Issue will be fixed.

| improve this answer | |
  • Thank you, really helped. I used next commands: 1) sudo add-apt-repository ppa:nilarimogard/webupd8 2) sudo apt-get update 3) sudo apt-get install notifyosdconfig – realmag777 Mar 8 '17 at 22:52
1

Simply updating the notify-osd may lead to you getting an additional error The following Schema is missing: com.canonical.desktop.interface.

The solution to this should be to:

sudo apt-get install unity-webapps-service

Though the background to this could be dependency issues. If so the command line could give a suggestion like try:

apt-get -f install

in which case you will want to:

sudo apt-get -f install

and this could well resolve the issue.

| improve this answer | |
0

I faced same issue. The following commands helped me,

sudo apt-get install overlay-scrollbar

and

sudo apt-get install notify-osd
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.