i just installed Ubuntu 11.04 fresh install with Windows 7 already installed.. when i chose ubuntu from the grub menu it shows the purple screen for too long with no activity from the laptop then after a while it boots normally. Is there a fix for that because really it takes tooooooo long.

dmesg reports the following:

[    3.078617] IP route cache hash table entries: 131072 (order: 8, 1048576 bytes)
[    3.080423] TCP established hash table entries: 524288 (order: 11, 8388608 bytes)
[    3.084959] TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
[    3.085502] TCP: Hash tables configured (established 524288 bind 65536)
[    3.085506] TCP reno registered
[    3.085524] UDP hash table entries: 2048 (order: 4, 65536 bytes)
[    3.085576] UDP-Lite hash table entries: 2048 (order: 4, 65536 bytes)
[    3.085736] NET: Registered protocol family 1
[  150.340039] pci 0000:00:13.5: EHCI: BIOS handoff failed (BIOS bug?) 01010001
[  150.340069] PCI: CLS mismatch (64 != 32), using 64 bytes
[  150.340088] pci 0000:01:05.0: Boot video device
[  150.340698] PCI-DMA: Disabling AGP.
[  150.340825] PCI-DMA: aperture base @ cc000000 size 65536 KB
[  150.340827] PCI-DMA: using GART IOMMU.
[  150.340831] PCI-DMA: Reserving 64MB of IOMMU area in the AGP aperture
[  150.344449] Simple Boot Flag at 0x44 set to 0x1
[  150.344892] audit: initializing netlink socket (disabled)
[  150.344906] type=2000 audit(1304603463.330:1): initialized
  • Can you press CTRL+ALT+F1 at boot and tell us what the system says?
    – RolandiXor
    Commented Apr 30, 2011 at 23:27
  • tried that and just a blanking underscore
    – Spaik
    Commented May 2, 2011 at 14:26
  • Please answer your own question and accept it - I see that you've solved your issue at ubuntuforums.org/showthread.php?p=10782711. Btw there's already a bug report at bugs.launchpad.net/bugs/781591
    – papukaija
    Commented May 13, 2011 at 13:39
  • Yeah i forgot about posting it here... finals are everywhere :)
    – Spaik
    Commented May 19, 2011 at 23:23
  • By the way, what is "too long"? just curios.
    – Alvar
    Commented Oct 3, 2011 at 20:36

5 Answers 5


Googling around, various reports mention that it may be due to a USB issue with your BIOS.

Suggestions range from

  1. Remove all USB devices to see if its resolved
  2. Disabling USB legacy in the BIOS
  3. Upgrade the BIOS to the latest firmware

However, I note the next item in your trace log is AGP - so possibly an issue with the video card? Are there any options in your BIOS which you can play with that relate to AGP/video card?

Suggest have a go with the above and report back.

  • thanks i already found that USB Legacy was the problem :D
    – Spaik
    Commented May 19, 2011 at 23:22

I Thought that I have the same problem here.

  1. I started modifiyng grub in xubuntu 10.04 deleting everything but xubuntu (because It recognized recovery partitions and windows 7 that was installed in another drive).
  2. When I restarted It took about 2 minutes to show my motherboard logo. By the while I was trying to press F2 but nothing happened.
  3. I found this thread and I saw that someone have problem with USB so I noticed that my kindle was charging connected by USB. So I just disconnected it and everything is working OK.

Perhaps unplugging a Kindle or similar device from your computer would fix this problem for you as well.


I had a similar issue with long/inconsistent boot. Error messages indicated AGP and video as well.

It turns out old Compaq USB Internet keyboard was the cause. Replacing it and testing a collection of USB keyboards and mice (and other devices) now shows a consistent boot time of just over two minutes (from Restart to available desktop)

No additional action was required


The answer depends little depending on how long the boot is. If it is a minute or more i suspect the ACPI. You could either shut it of from the Grub-menu or in the BIOS. The Grub way you will need go into edit mode by pressing "e" and at the row that say "quiet splash" add "acpi=off". Then press "ctrl+x" to boot. This is not a permanent solution. Try it first and if it work you could do it permanent.

  • tried that and it just takes longer and then it never boots :(
    – Spaik
    Commented May 4, 2011 at 10:33
  • Could you right after upstart open the terminal and then write "dmesg". Take that output and copy it to pastebin.com and link to it here.
    – AlMehdi
    Commented May 4, 2011 at 17:42
  • pastebin.com/8Sci1WYk
    – Spaik
    Commented May 5, 2011 at 14:39
  • @Spaik I am sorry but i am too inexperienced.. i clearly see a problem. It might be the USB but am fairly certain it is the kernel. Make a bugreport with the dmesg output on launchpad. It might give you a better answer.
    – AlMehdi
    Commented May 6, 2011 at 12:31
  • no need to be sorry :) i am thanks-full for your attempt to help me :) i will do the bug report and wait for the answer. thanks again :)
    – Spaik
    Commented May 6, 2011 at 14:13

I had problem with login and boot time also, reason was in xorg.conf file configuration Problem was coming from synaptics touchpad, where the special .conf file was created to make a scrolling work.

Below is outtake from launchpad bug report my comment, how I made scrolling work https://bugs.launchpad.net/ubuntu/+source/linux/+bug/565543

It was annoying to be without scrolling, so created a file with name psmouse.conf in:


with text inside:

options psmouse proto=imps

Saved and run through commands:

sudo modprobe -r psmouse
sudo modprobe psmouse

After this my ALPS is detected as ImPS/2 Generic Wheel Mouse, but scrolling is working

After making this, I totally forgot about xorg.conf, that I had a Section InputDevice with assigning a driver to my touchpad, what was creating and error, because after making scrolling to work my touchpad was recognized as imPS2 mouse, but not as Synaptics Touchpad... so it was causing the long LOGIN time and partly a boot time

X was trying to find Synaptics Touchpad but there was imPS assigned Physically, so this so to speak searching time made an interface to stuck...


Simply comment out Section InputDevice and InputeDevice in Server Layout in xorg.conf

It solved the problem in my case, hope it will help someone

  • This looks unrelated.
    – Mahesh
    Commented Nov 18, 2012 at 13:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .