During the "install" phase of the upgrade there was a power failure. After when starting up again the following errors are reported:

init: udevtrigger main process (420) terminated with status 1
init: udevtrigger post-stop process (428) terminated with status 1
init: udevmonitor main process (419) killed by TERM signal
The disk drive for / is not ready yet or not present
Continue to wait; or press S to skip mounting or M for manual recovery

Pressing M gives me the following message:

Root filesystem check failed.
A maintenance shell will now be started.
CONTROL-D will terminate this shell and reboot the system.
  • This sounds the same as this question, which I partially answered there. Unfortunately I don't remember everything I did, but it should let you boot at least. May 2, 2011 at 1:09

4 Answers 4


I had the same situation happen -- power failure during upgrade.

Get to the maintenance shell, and try this:

sudo mount -o remount,rw /
sudo  dpkg --configure -a
sudo mount -o remount,ro /
sudo sync
sudo reboot

(the remount/sync at the end is probably just paranoia, but just in case...)

  • Thank you, mount -o remount,rw /; dpkg --configure -a; reboot; worked! I had to skip the final remount/sync though and jump straight to reboot as the drive was busy. Cheers.
    – Gerry
    Jun 4, 2011 at 5:31
  • +1 Worked totally (crashed update). Line 3 says "/ is busy" though. Aug 10, 2012 at 15:30
  • while processing with second line, i got this error "Processing was halted because there were too many errors" Oct 26, 2013 at 6:29
  • Consider adding umount / and fsck before the other commands to clear any bad disk stuff. Mar 18, 2014 at 21:10

When you get to this root shell, type fdisk -l to get a list of the drives in the system, then do a fsck on the / (using it's name from the list, for example /dev/sd5 partition.

To force a disk check, use sudo fsck -f.

  • It says it is clean I have installed Ubuntu on another partition to presently I have 3 Ubuntu installation 1. My original Ubuntu 10.10 which got messed up when i was trying to upgrade 2. A part of Ubuntu 11.04 Which I was upgrading to when this problem started. 3. The New installation I am a total newbie so pardon my questions. Is there any way I can use the working installation (3) to sort it all out?
    – Oo Nwoye
    May 1, 2011 at 7:44
  • @OoNwoye: most likely, you may need to force the file system check (I will update my answer later)
    – RolandiXor
    May 1, 2011 at 13:28
  • @OoNwoye: Does this solution work for you. Oct 26, 2013 at 6:42
  • what im facing is commented in reply askubuntu.com/questions/38617/… Oct 26, 2013 at 6:52

I had the same problem (power failure during upgrade). In my case the system was frozen after showing the error message: pressing S or M (or any other key) didn't have any effect.

I fixed it by following @scott-wood's instructions. Just a little addenda: to enter the maintenance shell you need to boot from a live disk and choose the options:

  1. Rescue a broken system;
  2. Choose the device to use as root file system (typically the first entry);
  3. Choose "Execute a shell in /dev/..." as rescue operation.

I forgot to execute the mount and sync commands and the system recovered successfully, so I think it's safe to skip them.

At the end remember to reboot the system by running "reboot". Alternatively you need to exit the shell either by typing "exit" or pressing CTRL+D; once you are out of the shell, choose the option "Reboot the system".


I experienced this error as well, but my problem (and thus the fix) were different.

After installing Ubuntu 11.04 successfully, I ran a dist-upgrade. For whatever reason, during the upgrade, it randomly changed the drive letter in /etc/fstab for all of my partitions that were not identified by UUIDs.

Editing /etc/fstab and fixing the drive letter fixed the problem for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .