38

I just added extension pack and my Windows machines won't start. This is the error I get:

Failed to open a session for the virtual machine Windoze 7.

The device helper structure version has changed.

If you have upgraded VirtualBox recently, please make sure you have terminated all VMs and upgraded any extension packs. If this error persists, try re-installing VirtualBox. (VERR_PDM_DEVHLPR3_VERSION_MISMATCH).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console
Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

I really don't want to re-install VB all over again, so I am hoping to find another solution. I tried some of the other suggested solutions but they didn't work for me. How can I fix this?

33

THE RIGHT WAY

Yes, other answers are right: you have a extension-virtualbox mismatch. However, there is a better way, a more Ubuntu way, to solve this using the distro's own installer which is packaged as virtualbox-ext-pack and found in the multiverse.

  1. If the multiverse is not enabled, enable the multiverse.
  2. Close out of VirtualBox.
  3. In the terminal, run sudo apt-get install virtualbox-ext-pack

if for any reason that's already installed and you want to have reinstalled (thus guaranteeing you fix all the problem).

sudo apt-get --reinstall install virtualbox-ext-pack
2
  • Is the version alwyas in sync with the VirtualBox in main repos? – betatester07 Mar 18 '16 at 18:16
  • @betatester07 yes. In fact, upgrading one will force an upgrade on the other, if required.. apt-cache depends virtualbox-ext-pack. You can see it currently (2016-03-18) depends on virtualbox 5.0. – Evan Carroll Mar 18 '16 at 22:25
22

The version of extension-pack MUST match the VirtualBox version.

You can do this easily in Ubuntu by running:

sudo apt-get --reinstall install virtualbox-ext-pack


If this still does not fix your issue, you can manually install the matching VirtualBox extenstion, by following the below instructions:

  1. Download the latest .deb file for Ubuntu from here:
    https://www.virtualbox.org/wiki/Linux_Downloads

  2. Double click on the downloaded .deb file. It will bring-up Software Centre.

  3. Click on the Upgrade button to install the latest version.
4
  • 2
    This error happened to me because I had the latest VB installed, but extension pack was not at the same version. Solved by clicking "File > Check for updates...", then it asked me to upgrade extension pack, and the issue was solved. – Augusto Destrero Jan 27 '16 at 10:27
  • In 5.0.14 the "Check for updates..." has vanished, so either manually download (lop off the ".deb" extension in links on virtualbox.org/wiki/Linux_Downloads) and then double click to install ( or go via File > Preferences > Extensions) – earcam Feb 17 '16 at 22:10
  • 1
    Downvoted because installing VirtualBox outside of the repo is a bad idea. VirtualBox requires kernel drivers. The ones you have now may work, but an upgrade to the kernel may actually break VirtualBox forcing you to have to go search for a new .deb. Also, you won't be getting security upgrades for this which is kind of vital. VirtualBox is better managed by the distro. You're better off installing the extension pack for the one that ships. – Evan Carroll Mar 17 '16 at 22:34
  • Conflicts with already installed VB version for me. – 4xy Feb 26 '17 at 14:32
5

As it has been already stated

The version of extension-pack MUST match the VirtualBox version.

But you don't need to install the latest version of VirtualBox - you just need to install matching extension pack.

You can find all older VirtualBox releases (and corresponding extension packs) at https://www.virtualbox.org/wiki/Download_Old_Builds - just download extension pack that strictly matches your currently installed VirtualBox. After you locate your major build number, click on

Extension Pack  All Platforms

to download the appropriate extension pack.

4
  • This is the correct answer – earcam Feb 17 '16 at 22:08
  • 2
    @earcam not really: this is a better answer – Evan Carroll Mar 17 '16 at 22:58
  • 2
    I see that solutions to this problem are still evolving towards better ones – betatester07 Mar 18 '16 at 18:15
  • 1
    @EvanCarroll +1 then. Though at time of writing it was the most correct answer 😛 – earcam Mar 21 '16 at 21:31
2

For VirtualBox Version: 5.0.2-102096~Ubuntu~trusty (I have it installed on Mint Rosa 64 Cinnamon 17.3)

1) in VirtualBox Manager:

file / preferences / extensions

  • remove the offending ext pack

2) download the right ext pack

from http://download.virtualbox.org/virtualbox

  • click on your version
  • download the extension pack (right-click, save link..)

3) in VirtualBox Manager

file / preferences / extensions

  • add the new ext pack
0

I was facing the issue while installing Kali linux.I disabled the usb controller and it started.Might not be the exact solution what you are looking for.But you can always give it a try. disable usb2.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.