I just upgraded to 11.04 and I'm having some trouble with the window manager.

When I log in there are no window borders around anything. Also when I log in it is running some theme that looks like it was designed in the 90's. But as soon as I bring up the "appearance" settings it flicks straight to the correct display theme: "ambience" without me changing anything!! Still no window borders tho, and at this point the icons on the desktop haven't changed to conform with "ambience" they still look like something out of windows 95 :|

Compiz is running, gtk-window-manager isn't, I can run it manually where I DO get borders, however the problem with the themes still remains. When I put a command to run gtk-window-manager in "startup" again it runs borders on startup, but the theme does the exact same thing.

I am using on board intel graphics, I know they have a bad reputation with Linux :\

VGA compatible controller: Intel Corporation 82G965 Integrated Graphics Controller (rev 02)

Also tried creating a new user account for test purposes and there was no problems with the theme in the new user account. Still no borders tho. THE PROBLEM WITH BORDERS WAS FIXED IN EDIT 3

Re-installing unity doesn't fix anything.


Problem half solved using the ham-handed approach of re-installing natty. I have window borders permanently now thank god! But when I log in at first my theme is still like windows 95, despite the fact I have it set to 'ambience', it stays like this until I go into 'appearance' where it automatically changes to the correct theme without me actually doing anything! everything reverts back to 'ambience' apart from icons on the desktop which still look ancient.

Here's the link to a screenshot of the problem:

Problem with theme

  • Suggest create a new user account via "Users and Groups" - login with that new account. Do you have the same issue? – fossfreedom Apr 30 '11 at 22:29
  • Just tried what you suggested, nothing wrong with the theme in the new account, still no window borders though. :\ – Grant Apr 30 '11 at 22:47
  • What graphics card are you using? In a terminal type "lspci | grep VGA". In addition - please edit your Question with your findings so that the extra information is more clearly visible. – fossfreedom Apr 30 '11 at 22:50
  • VGA compatible controller: Intel Corporation 82G965 Integrated Graphics Controller (rev 02), i know they have a bad repuation with linux :\ – Grant Apr 30 '11 at 22:53
  • The lack of window borders could be the theme. Do you have window titles? – RolandiXor Apr 30 '11 at 23:28

From what I've read, Compiz has difficulties supporting the 82G965 chipset. My suggestion would be to login using the Ubuntu Classic Session (bottom of the screen on the logon box) and once logged in, install Unity-2D from the software-centre. Logout, and login, but this time with the Unity-2D session.

  • couldn't find the software centre under the ubuntu-classic session, its not in the same place as it was in 10.10. did go into the synaptic-package-manager tho and re-installed unity, this didn't do anything. – Grant May 1 '11 at 0:08
  • In synaptic search for "unity" - you should see "unity-2d" 4th search result down. – fossfreedom May 1 '11 at 8:50
  • Thanks found it. I installed in and logged into a unity-2d session, got borders yeah, the theme is still misbehaving tho. This time the top bar seems to be fine but the icons for everything else are in that windows 95 style theme. – Grant May 1 '11 at 14:21
  • This sounds bizarre - is this the same observation for the newly created user as well? – fossfreedom May 1 '11 at 14:30
  • 1
    since it was just the theme that was wrong after i re-installed natty, i did a search on this problem by itself and found that "killall nautilus" worked, so i added this command to startup. no idea why it works, would be interesting to find out, however at least its sorted for the time being. thanks for your help. :) – Grant May 3 '11 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.