So when I do dpkg --get-selections | grep vmware I get...

vmware-tools-core               install
vmware-tools-esx-nox                install
vmware-tools-foundation             install
vmware-tools-guestlib               purge
vmware-tools-libraries-nox          install
vmware-tools-plugins-autoupgrade        install
vmware-tools-plugins-deploypkg          install
vmware-tools-plugins-guestinfo          install
vmware-tools-plugins-hgfsserver         install
vmware-tools-plugins-powerops           install
vmware-tools-plugins-timesync           install
vmware-tools-plugins-vix            install
vmware-tools-plugins-vmbackup           install
vmware-tools-services               install

I would like to remove these. So for instance when I do...

sudo apt-get -f remove vmware-tools-core

I get...

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 linux-image-virtual : Depends: linux-image-3.2.0-57-virtual but it is not going to be installed
 linux-server : Depends: linux-headers-server (= but is to be installed
 vmware-tools-esx-nox : Depends: vmware-tools-core (>= 9.0.5) but it is not going to be installed
 vmware-tools-plugins-autoupgrade : Depends: vmware-tools-core-9.0.5
 vmware-tools-plugins-deploypkg : Depends: vmware-tools-core-9.0.5
 vmware-tools-plugins-guestinfo : Depends: vmware-tools-core-9.0.5
 vmware-tools-plugins-hgfsserver : Depends: vmware-tools-core-9.0.5
 vmware-tools-plugins-powerops : Depends: vmware-tools-core-9.0.5
 vmware-tools-plugins-timesync : Depends: vmware-tools-core-9.0.5
 vmware-tools-plugins-vix : Depends: vmware-tools-core-9.0.5
 vmware-tools-plugins-vmbackup : Depends: vmware-tools-core-9.0.5
 vmware-tools-services : Depends: vmware-tools-core-9.0.5
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

If I run apt-get -f install I get...

After this operation, 36.3 MB of additional disk space will be used.
Do you want to continue [Y/n]? 
(Reading database ... 464964 files and directories currently installed.)
Unpacking linux-image-3.2.0-57-virtual (from .../linux-image-3.2.0-57-virtual_3.2.0-57.87_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/linux-image-3.2.0-57-virtual_3.2.0-57.87_amd64.deb (--unpack):
 failed in write on buffer copy for backend dpkg-deb during `./boot/abi-3.2.0-57-virtual': No space left on device
No apport report written because the error message indicates a disk full error
                                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-57-virtual /boot/vmlinuz-3.2.0-57-virtual
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-57-virtual /boot/vmlinuz-3.2.0-57-virtual
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
johnmlocklear@vweb-dev:~$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree       

Here is the output of dpkg -l 'linux*' http://pastie.org/8528966

My goal is to remove the vmware tools packages. Any help appreciated...


Your problem comes dual. First, you have /boot full of scrub. You need to scrub it! Run dpkg -l 'linux*' and remove the old non-used kernels. That will solve the sudo apt-get -f install problem. The next one you need to remove all the packages in one swoop:

sudo apt-get remove linux-image-server linux-server linux-image-3.2.0-48-virtual linux-image-3.2.0-51-generic linux-image-3.2.0-51-virtual  linux-image-3.2.0-52-generic linux-image-3.2.0-52-virtual linux-image-3.2.0-53-generic linux-image-3.2.0-53-virtual linux-image-3.2.0-56-generic linux-image-3.2.0-56-virtual
sudo apt-get -f install
sudo apt-get autoremove  vmware-tools-esx-nox vmware-tools-services vmware-tools-plugins-* vmware-tools-core
sudo apt-get install linux-server linux-headers-server

That should solve your problem

| improve this answer | |
  • OK, I am trying to get rid of images using the script from this post ubuntuforums.org/showthread.php?t=1435818. Each image gives me this error pastie.org/8528865. Any ideas what the issue is? – Mark Locklear Dec 4 '13 at 18:39
  • @Lumbee is there a problem specifying them manually? Like sudo apt-get remove linux-image-version-generic? Why use the script? Also to see if there's indeed a problem you may want to edit your question and add the output of dpkg -l 'linux*' and sudo apt-get cache. – Braiam Dec 4 '13 at 19:00
  • When I do sudo apt-get remove linux-image-3.2.0-54-gen I get pastie.org/8528960 – Mark Locklear Dec 4 '13 at 19:18
  • @Lumbee the output still lacks. Where is sudo apt-get check and dpkg -l 'linux*'? – Braiam Dec 4 '13 at 20:04
  • I need the complete package list. Please, do not remove anything of the information asked I need to know exactly all the packages that you have installed. – Braiam Dec 5 '13 at 15:05

I have the same problem and I found some useful information on this site (it's in french).

When I did a di -f command I found that all the i-nodes where being used (100%, please correct me if I'm saying something wrong).

So you should try emptying /usr/src and see if it works.

EDIT: just tested this solution and it worked, I deleted some folders in /urs/src and then I could execute the apt-get -f install command.

| improve this answer | |
  • This can potentially damage your system as none apt or dpkg knows that the files is not longer there. – Braiam Dec 27 '13 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.