2

Trying to follow these instructions: Using ALT + Keycode for accents?

to make typing accents easier (and consistent between OSX at work and Ubuntu at home) and I can't for the life of me figure out how to set a compose key. In my Keyboard Shortcuts I see that "Compose Key" is disabled but no amount of right clicking or double clicking will let me enable it. For keys that aren't disabled, just selecting the entry gives me a "new accelerator ..." option. But not for Compose.

I tried to follow the instructions on How to set compose key to pause in 13.10? but my right alt key still pulls up the HUD.

PS. I do wish that What are Unity's keyboard and mouse shortcuts? were updated for 13.10

6
  • I also use OS X for work, and would like to be able to use the ALT key as the Compose key. I haven't actually tried setting it up, but my initial guess is that you won't be able to use any key used by Unity, meaning the Ctrl or Alt keys. – iBelieve Dec 4 '13 at 15:36
  • That can't be. Except of course...sigh. – Amanda Dec 5 '13 at 12:56
  • what is xev reporting for the left and right alt-s respectively? – falconer Dec 19 '13 at 18:01
  • xev reports that the right alt is a multi key. And, um ... multi-,-c does indeed produce ç and does not pull up the HUD. So I guess if you want to tell me it works I can accept that answer and you can have awesome 50 reputation. Since I can't solve a problem that isn't a problem. – Amanda Dec 19 '13 at 23:22
  • I honestly have 0 idea what changed, because a week ago it was indeed pulling up the HUD. – Amanda Dec 19 '13 at 23:24
2
+50

The general way to troubleshoot such a problem is:

  • Look in the layout settings whether there is a layout which provides the feature you want to look. Also check there whether you can change the options for a certain layout to behave the way you would like.

  • Look in xev for the keycodes and keysym of the left and right ALT respectively, and reconfigure it with xkbcomp so the right ALT has the ISO_Level3_Shift keysym. Following is the relevant section from my XKB layout:

    key <RALT> {
    type= "ONE_LEVEL",
    symbols[Group1]= [ ISO_Level3_Shift ]
    };
    

    To get your layout use

    xkbcomp $DISPLAY keylayout.xkb 
    

    and edit it in a text editor. To upload it to the Xserver use

    xkbcomp keylayout.xkb $DISPLAY
    

    If it works you have to make it permanent by writing a script with the previous command in it and making it autorun on startup. (You can make it autorun either with the /etc/lightdm/lightdm.conf file or any other way you like.)

  • If the right ALT has the proper keysym and some keys with the right ALT key produces the desired output, but some others don't, then only change the keysyms for that ill behaving key. More instructions for this situation here.

  • If none of the above works, then it is possible that you have a special, programmable keyboard, which was programed in a way that it sends the same scancode for the left and right ALT keys, so the kernel sees them the same. In this case either reset your keyboard or program it correctly. Check this Q&A for a similar problem.

P.S. There is a good wiki about linux and keyboards here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.