I have a virtualbox running ubuntu 13.10 (running on a 13.10 host) that has two shared folders on the host that are mounted at boot. A while ago the guest ran some updates that broke the folder sharing, the guest could no longer see the devices to mount them. I had a hunch from reading around that it might be something to do with the guest additions, as getting the 4.3 release of virtualbox from the oracle repo and updating the guest additions solved the problem. The issue is, today's linux headers update broke the mount again, and there doesn't appear to be an updated guest additions to go to! (re-installing them doesn't work).

Obviously at a basic level, not installing the updates would prevent this problem. However I'd be interested in finding out exactly why it's behaving like this.

I'm a bit out of my depth here but if someone could point me in the right direction of a solution I'd appreciate it.

If there's more useful info I can provide let me know.

Full error message I'm now getting when trying to use the manager to mount the Guest Additions CD Image:

Unable to access "VBOXADDITIONS_4.3.4_91027"

Error mounting /dev/sr0 at /media/ptinkler/VBOXADDITIONS_4.3.4_91027: Command-line 'mount -t "iso9660" -o "uheper=udisks2,nodev,nosuid,uid=100,gid=1000,iocharset=utf8,mode=0400,dmode=0500" "/dev/sr0" "/media/maplecroft/VBOXADDITIONS_4.3.4_91027" exited with non-zero exit stats 32: mount: unknown filesystem type 'iso9660'

  • What error do you get on failing to resinstall the guest additions?
    – Takkat
    Dec 4, 2013 at 9:56
  • No error, it just doesn't fix the problem.
    – ptr
    Dec 4, 2013 at 9:59
  • See if the virtualbox shared folders kernel module is loaded with lsmod | grep vboxsf.
    – Takkat
    Dec 4, 2013 at 10:16
  • no output at all from that command, lsmod | grep vbox has no output at all either actually.
    – ptr
    Dec 4, 2013 at 10:19
  • Then you need to reinstall the guest additions. Sometime we have to do this more than once to finally get them working...
    – Takkat
    Dec 4, 2013 at 10:22

3 Answers 3


Virtual Box shared folders functionality depends on guest additions kernel modules. A kernel update should automatically reload all modules using dkms (which should be installed by default).

Unfortunately this does not always work as expected. Then we have to reinstall the guest additions:

Guest additions will then be available after a reboot of the guest.

If this fails it is worth to try again as sometimes the installation does not work as expected (without errors or warnings).

It may also worth to try to remove the guest additions before we install them again using the uninstall script (replace x.x.xxx with your version of Virtual Box):

cd /opt/<VirtualBoxAddtions-x.x.xx>/
sudo ./uninstall.sh
  • Looks like dkms wasn't installed on the guest. Installed it now. I'd like to reinstall the guest additions, however now when I try to mount the Guest Additions CD Image, I get an error: Unable to mount VBOXADDITIONS_4.3.4_91027 to do with unknown filesystem type 'iso9660'
    – ptr
    Dec 4, 2013 at 10:45
  • That's what I'm trying to do.
    – ptr
    Dec 4, 2013 at 10:51
  • Added the full error message to the OP
    – ptr
    Dec 4, 2013 at 10:59
  • would you prefer I make the secondary issue a separate question?
    – ptr
    Dec 4, 2013 at 12:05
  • fairly certain the .iso is ok, I tried it and it worked just fine on an older cloned .vdi of the virtual machine. How do I mount manually?
    – ptr
    Dec 4, 2013 at 12:42

This worked! My internet was working from guest OS. So I could download the additions ISO and extract. Also was able to install it easily

I also had taken two steps before this (not sure if they helped, but they shouldnt hurt since the steps downloaded all headers and prepped kernel for guest adds)


sudo apt-get install build-essential module-assistant
sudo m-a prepare

Open Ubuntu in VirtualBox. Open FireFox and go here.

Find your version of Virtualbox and click the link to open it.

Download your version of VBoxGuestAdditions (iso):

Open it in Archive manager and extract files


sudo VBoxLinuxAdditions.run


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.