Now that I've changed to 13.10, I can't get a grub menu. I found this out the hard way when something about installing then removing KDE plasma desktop made it so ubuntu stopped booting between the start screen and the login. I had to make a fresh install. Now that I have, I've tried again to get a grub menu. Holding down shift does not work. Here is what my /etc/defaults/grub file had on fresh install:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Hypothetically, this should make grub menu visible for 10 seconds (GRUB_TIMEOUT=10). It is not. It also doesn't even take 10 seconds for my computer to go from starting grub to the login screen. I tried changing to


which did cause a 5 second countdown to be displayed, but hitting shift, once again had no effect.

What's going on?


I also had that problem and just commenting out the hidden flags:


was enough. That way I did not have to run the boot-repair scripts which are pretty heavy and do many other things that I wasn't sure I would want applied to my system.

Important note: don't forget to run:

sudo update-grub

or your changes won't be recorded in grub and thus they will be useless.


It turns out that this is a known bug: https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1227365

running boot-repair (https://help.ubuntu.com/community/Boot-Repair) "fixes" the problem: it makes the menu display, however this stops working if one tries to use the hidden time-out. Although I have also found that this issue with pressing shift still not working after setting GRUB_HIDDEN_TIMEOUT=x is either machine or install-method dependant. It works as it should on my laptop which has 13.10 as an upgrade from 13.04, whereas my desktop is running 13.10 installed from a live usb.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.