When i type gedit in dash i HAVE TO type the complete name gedit to open gedit. Same for empathy, ktorrent and any other program. In ubuntu 10.10 for example i would do an ALT+F2 and then i just type ged and the launcher would see what GUI programs i had for ged (Since gedit was the only one) the launcher would open gedit. Same for typing ktorrent. I would only need to type kto or for empathy only emp. Quicker and you do not need to type the whole thing. more friendlier if you ask me.

For what i see right now, dash has something that the previous launcher did not, you can type torrent and he would mention ktorrent the result list. This would not have worked in the previous one since the word you start typing is how the launcher assumes the command starts.

Dash only needs the option to execute the first GUI program that resembles the word typed. With ged he should be able to open gedit instead of trying to execute the command ged. With emp he should be able to open empathy when i press enter and so on..

How can i change the behavior of this so it works as the previous launcher.

UPDATE: The problem arises when i use ALT+F2 instead of the SUPER key. Both will make DASH (At least the visual Dash) but it will not behave the same.

The following images show ALT+F2 DASH and SUPER DASH

enter image description here

enter image description here

AS you can see, when using the ALT+F2 method it does not show the correct GUI tools. When using the SUPER method it does. This was the problem. Now how do i make it so both behave the same way. The SUPER method does not appear on the Keyboard Shortcuts.

  • I am a bit confused on your question. I can open the Dash by pressing the Ubuntu button. If I type even just "ge", Text Editor is the first choice in the list. And it works similarly in the bonus Alt+F2 runner mode. – Jeremy Bicha Apr 30 '11 at 19:14
  • Are we talking about Unity launcher or the lightweight shell, dash? – Oli Apr 30 '11 at 19:18
  • For gedit i see i can type the alternative "text editor" but for empathy? – Luis Alvarado Apr 30 '11 at 19:24
  • I do not know what happened but 10 seconds after testing it is working as i wanted to. Does dash need for one to run a program for the first time so it appears correctly in the list or what? – Luis Alvarado Apr 30 '11 at 19:28
  • Found the problem. When pressing ALT+F2 the "Dash" that appears does not behave the same way as the "Dash" that appears when pressing the Super button. I will put this info and images up in the question. – Luis Alvarado Apr 30 '11 at 19:30

I would not advise trying to change the behavior of Alt+F2 since Alt+F2 is intended to be used to execute commands. If you want autocompletion, use the super button (windows key) instead. Changing the Alt+F2 command to behave like the super command would make it more difficult for you to do something complicated like cd /foo/bar/ ; cut [options] <baz | tee qux >quux, as the super dash won't accept commands like that, and the alt+F2 dash wouldn't be accessible via a shortcut. You'd have to open a terminal.

  • Did not test scripting in the ALT F2 dash – Luis Alvarado May 5 '11 at 18:32
  • So I just realized that my example is rubbish since Alt+F2 isn't a shell. So you can't do redirection or most other fancy tricks. But you can still e.g. invoke a shell and then have it execute your commands. – Kevin May 5 '11 at 18:37
  • Then the difference is basically one searches for your most used apps and checks for GUI based ones and the other searches for everything. – Luis Alvarado May 5 '11 at 18:42
  • Yes, but you can pass arguments with Alt+F2 (so e.g. rm /foo/bar). In theory it should be possible to invoke a shell and pass arbitrary fancy commands (with redirection etc.) to it, but I haven't been able to get that to work... – Kevin May 5 '11 at 18:55

The difference is:

ALT+F2 DASH - Shows all commands including terminal ones and does not try to guess the command.

SUPER DASH - Shows only GUI programs and tries to guess what program you want to run depending of the amount you use them.

Got to this answer after testing for almost 2 days.


Is this because gedit's launcher is actually named "Text Editor"? If it is, two possible solutions:

  1. Rename the launcher to call it "gedit" - You know what "gedit" means so it's hardly a usability issue for you.
  2. Create a script in ~/bin/ called g or ged that launches gedit. Then you just have to pump that in, hit return and it'll call that script.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.