I have a brand new Toshiba Satellite S50-A that came loaded with Windows 8.1. I would like to live boot Ubuntu from a USB drive, or failing that, a DVD. (I do not want to install Ubuntu on this machine).

Whenever I attempt to boot the install/live Ubuntu 13.10 from either a USB drive or a DVD, it loads the GRUB boot menu, but selecting any option results in the same results: The screen goes blank, the USB or DVD drive blinks a couple of times then goes dark, and nothing else happens. Booting will work if the Setup Utility is configured for "CSM Boot", but this mode fails to boot the Windows 8.1 install.

I have read dozens of threads about this and similar issues, but none of those seem to apply exactly to my experience. I have tried a number of suggestions from those threads, without success:

  • Computer Setup utility is at latest available version
  • Secure Boot can be either on or off, with no effect
  • Fast Boot is disabled
  • Windows 8 Fast Startup is disabled
  • Computer setup has no "Intel Speed Step" setting
  • I have verified that the computer is booting the DVD/USB in UEFI mode, as per https://help.ubuntu.com/community/UEFI#Identifying_if_the_computer_boots_the_Ubuntu_DVD_in_EFI_mode
  • Computer setup has only two Boot Modes, "UEFI Boot" and "CSM Boot", which apply to all drives.
  • Setting Boot Mode to "CSM Boot" allows successful boot of Ubuntu 13.10 from both USB and DVD. However, the computer then fails to boot Windows 8.1, so this is not an acceptable solution. It is not possible to configure UEFI/CSM per drive.
  • I have tried standard DVD from iso, USB from iso using Unetbootin, and USB from iso using dd. All fail to boot in UEFI mode in the same way.


I have tried the following kernel options without effect:


Update 2:

I don't know if this will provide any useful information: When I boot to USB, I reach the GRUB menu. If I press 'c' for command line, then manually input the lines that are present in the grub.cfg file for "Try Ubuntu without installing" ...

set gfxpayload=keep
linux /casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
initrd /casper/initrd.lz

... then all three of these command succeed. But when I issue the boot command, the light on my USB drive immediately turns off, with no further output to the screen.

Partial Resolution:

As per oldfred's suggestion, disabling the integrated NIC allowed the computer to boot from USB in UEFI mode. Of course, the ethernet adapter is now completely disabled, so it is not exactly a proper solution, but it's a step in the right direction!

This does not seem to be strictly a driver issue. Disabling the appropriate kernel driver module via GRUB command line (by appending modprobe.blacklist=alx, which I have previously verified as successfully disabling the ethernet driver) does not result in a successful boot if the LAN port is enabled in the computer setup. Something else must be going on.

Again, I do not wish to install Ubuntu to this machine; only boot from USB/DVD. And configuring the laptop in "CMS Boot" mode does work for both USB and DVD, but it is not an option as it renders Windows 8.1 unbootable. Any other suggestions are appreciated.

  • UEFI is largely hardware/firmware dependent...so you need someone with exactly the same hardware/firmware to produce a reliable answer. – RobotHumans Dec 2 '13 at 22:43

A user posted this in the forum who had a P50.

Turned NIC (Integrated Network Interface Controller) off and then booted off of USB. Was NOT an issue with any Linux distro just a quirk of the laptop. Am now running 13.10 daily and everything works. Also had to stick with EFI boot ON, Secure Boot disabled. Wouldn't boot off of any media or HDD when mode set to CSM.


Another user with P75

Toshiba Satellite P75 intel hd 4600 needed both:

acpi_osi=Linux acpi_backlight=vendor

  • Holy crap. Disabling the integrated NIC worked. Big strike against Toshiba in my book. – ellocogato Dec 4 '13 at 12:38
  • Does turning that off cause any Ethernet issues? I thought that was the Ethernet controller or just a setting by Toshiba that does not really work? – oldfred Dec 4 '13 at 18:09
  • Excellent point. Yes, the ethernet adapter is now completely disabled. In my case, I am only using the WiFi adapter anyway, so it is an acceptable sacrifice for now. – ellocogato Dec 4 '13 at 20:24
  • Can you now turn it back on, since Ubuntu is installed, or will it just not use Ethernet & USB at same time? – oldfred Dec 5 '13 at 5:11
  • As I mentioned, I do not wish to install Ubuntu on this machine, only live boot from USB. So I do not know if it is possible to turn ethernet back on after installation. – ellocogato Dec 5 '13 at 11:54

If you get to the grub menu (NOT the syslinux linux menu) in UEFI mode with secure boot on, you have booted. Your machine has successfully run the Microsoft signed shim.efi, which has successfully run the Canonical signed grubx64.efi. Now I know of some problems with getting chainloader to successfully run anything, but that's not your problem. Sounds like a video problem, so at the grub menu, type "e" to edit (instructions at bottom of screen), and try entering nomodeset where the "quiet splash" occur on the linux kernel line. Other things to try:


Good luck.

  • Thanks for your suggestions. Unfortunately none of the options had any effect. I have updated my original post to reflect this. Also, it is worth pointing out that both the DVD and the USB boot just fine if the computer is in "CSM Boot" mode, so the problem is definitely related to UEFI mode. – ellocogato Dec 3 '13 at 2:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.