I can't get screenlets to open. I've newly installed it on 11.04. Clicking the icon in the applications menu doesn't do anything. I'm on an Acer 4810T timeline laptop.

Here is the terminal output when I run screenlets-manager:

Create autostarter for: Screenlets Daemon
Traceback (most recent call last):
  File "/usr/share/screenlets-manager/screenlets-manager.py", line 1332, in <module>
    app = ScreenletsManager()
  File "/usr/share/screenlets-manager/screenlets-manager.py", line 103, in __init__
  File "/usr/lib/pymodules/python2.7/screenlets/utils.py", line 604, in lookup_daemon_autostart
    f = open(starter, 'w')
IOError: [Errno 13] Permission denied: '/home/seamus/.config/autostart/Screenlets Daemon.desktop'

When I run sudo screenlets-manager I get something about most things being disabled because I'm running as root. I guess the problem is that screenlets needs access to stuff that a normal user doesn't have? Can I get around this?

There is no file Screenlets Daemon.desktop in /home/seamus/.config/autostart/. Nor is there one in /usr/share/applications although there is a screenlets-manager.desktop there...

  • I think screenlets will not work at 11.04, especially on Unity. – Extender May 2 '11 at 15:00

I suggest to make sure all files and directory under you home belong to you. Run this command

find ~ ! -user $USER -o ! -group $USER

to check this. This other command to repair

sudo chown -R $USER:$USER ~

Then retry screenlets-manager. If you have the same result, post the output of

ls -ld ~/ ~/.config/ ~/.config/autostart/

As a note, never use sudo when it is not required.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.