I took a week off of work and brought my laptop with me. When I got back, the mouse and keyboard I use weren't working anymore.

Both devices work in my BIOS. The keyboard works in grub. Neither works in a virtual console (I installed gpm to check the mouse) or in xorg. I see messages about unplugging each in dmesg. I've tried removing all other peripherals except for each of these two input devices.

lsusb lists both items:

$ lsusb
Bus 002 Device 004: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications Processor
Bus 002 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver                     <---
Bus 002 Device 006: ID 045e:00db Microsoft Corp. Natural Ergonomic Keyboard 4000 V1.0 <---
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 1bcf:2b83 Sunplus Innovation Technology Inc. 
Bus 001 Device 003: ID 413c:8187 Dell Computer Corp. DW375 Bluetooth Module
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

But hardinfo sees nothing:


I've been using linux as my primary OS for ~12 years and this has me stymied.

The only lead I've got so far is that I was tinkering with grub to change my virtual terminal resolution. I saw that that affects mouse and keyboard on some systems, so I undid the changes and updated grub. I'm still get a text grub, but I think that was the case before I made the changes.

Oh yeah, I've also been having power issues. The machine doesn't poweroff or reboot anymore. No idea when this started - I only noticed when I took it home. I'm not trying to tack that on to this ticket, but am listing it as a clue on the off chance it's related.

My laptop in question is a Dell e6420.


Ok. I haven't figured out how my machine reach this state, but I think I've got the problem solved.

I booted from the live cd and copied some logs and such to my hard drive so I could compare against the system when it was running. One of these items was the output of lsmod. The livecd was using hid, usbhid, hid_microsoft, and hid_logitech_dj. Aside from my only microsoft device being my keyboard and my only logitech device being my mouse, I remembered hid was necessary to get my usb joysticks working way back when.

modprobe didn't fix the problem - the modules were all missing. (Still not sure how this happened.)

To install the modules I needed my kernel's extra drivers package. I included the kernel itself, just in case I needed a reinstall. sudo apt-get install linux-image-{,extra-}uname -r

After that, modprobe added the usb devices and I was good to go.

| improve this answer | |

Try restarting your mouse or touch pad using Xinput

first you should know the id of your device

In the terminal type :


A list with input devices will appear , notice the id of your target device then type

xinput --disable id
xinput --enable id
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.