0

I am using Ubuntu 13.04 version and I install LAMP server , php and MYSql.
Install PhpmyAdmin

sudo apt-get install phpmyadmin

I insert line in /etc/apache2/apache2.conf by using:

sudo gedit /etc/apache2/apache2.conf

Insert line in "# Include the virtual host configurations:"

Include /etc/phpmyadmin/apache.conf

When I restart apache2 by using:

sudo /etc/init.d/apache2 restart

This give me error:

apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
NameVirtualHost *:80 has no VirtualHosts

... waiting apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName

Kindly help me to solve this problem?

  • How did you install apache2 and phpmyadmin? With apt-get install apache2 and apt-get install phpmyadmin? – rechengehirn Dec 2 '13 at 9:51
  • I follow the following link to install apache2 1 – Zeb Dec 2 '13 at 9:58
  • what happens when you open http ://localhost/phpmyadmin without adding the line in apache.conf? – rechengehirn Dec 2 '13 at 10:12
  • Not Found The requested URL /phpmyadmin was not found on this server. Apache/2.2.22 (Ubuntu) Server at localhost Port 80 – Zeb Dec 2 '13 at 10:22
0

It is:

Include /etc/phpmyadmin/apache.conf

Not: Include /etc/phpmyadmin/apache2.conf

Just delete the 2 and it should work.

  • Now when I edit it save file option disable and I can't save it. Why? How can I reach it? – Zeb Dec 2 '13 at 10:49
  • Probably you forgot to open it with sudo: sudo gedit /etc/apache2/apache2.conf – rechengehirn Dec 2 '13 at 10:55
  • Yes you right, I forget to open it with sudo. – Zeb Dec 2 '13 at 11:09
  • If the answer is solving your problem now, pleas accept it by clicking the "accept tick" on the left side – rechengehirn Dec 2 '13 at 11:10
  • The problem is not completely solved .When I restart :sudo /etc/init.d/apache2 restart. It give error: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName NameVirtualHost *:80 has no VirtualHosts – Zeb Dec 2 '13 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.