I do not know much about networking, so I need some help here. I have used Ubuntu since 8.04 and my WiFi has worked ever since. I upgraded to 11.04 today. After first boot (with a LiveCD) my the widget listed my home network, but I could not connect to it. It is protected with WPA. I have found some random terminal commands online in case that could help you figure out what is wrong here.


lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

ole@ole:~$ ifconfig 
eth0      Link encap:Ethernet  HWaddr 00:16:d4:4d:dd:0f  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::216:d4ff:fe4d:dd0f/64 Scope:Link
          RX packets:3179 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2721 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3846076 (3.8 MB)  TX bytes:340839 (340.8 KB)
          Interrupt:21 Base address:0x6800 

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:720 (720.0 B)  TX bytes:720 (720.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:16:cf:9b:da:1f  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


... (shortened) ...
06:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
06:02.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
... (shortened) ...


I have been playing around to try and get it around. Since I don't know what I am doing I am trying random things. Thus far I think I have found a way to connect that works everytime.

  1. Boot the laptop while connected with a cable.
  2. Disable WiFi by right clicking the network manager
  3. Disable WiFi by using the physical button on my laptop
  4. Enable WiFi with said button
  5. Enable WiFi by right clicking the network manager
  6. After a little while it connects

Could it be related to this problem?

Any novel ideas on what this might be related to? Is there a setting that isn't properly enabled during booting?

Update 2

I tried to do the steps above without being connected with a cable on boot (Step 1) but it didn't work. But the moment I plugged in the cable, it must have kickstarted the Network Manager, because it immediately started connecting to my wireless.

I strongly feel that this is issue is connected to Network Manager not being initialized correctly. Any one with intimate knowledge of NM who can enlighten me? Or maybe even tell me how to test reinitializing NM after boot?

  • Does the Network Manager shows available Wifi networks? And what kind of error does it produce when you try to connect to the Home Network? If it's WPA protected, did you enter the correct key to authorize?
    – Dananjaya
    Apr 30 '11 at 16:04
  • @Dananjaya It was only after install that NM listed my home network and tried to connect to it. I did not get any error messages, it simply prompted me for the WPA-key again (yes it was entered correctly). At every reboot since then, the NM doesn't list any networks available at all. May 1 '11 at 7:45
  • 1
    well, this is not technically a solution, but have you tried booting from a 2.35.X.X kernel instead of 2.38.X.X one that 11.04 offer? I see lots of bug reports in Launchpad regarding 11.04 kernel's issues with wifi. Maybe until they fix it with a patch, you may use wifi as normal in 2.35.X.X kernel..
    – Dananjaya
    May 1 '11 at 8:57
  • I have the exact same issue on a 4320s HP probook. Upgraded to 11.04 and now it shows listed wireless networks but does not connect to any of them. I click them and nothing happens. I've installed all the backport packages available in synaptics with no change. I guess I will just have to wait for a patch to be released.
    – user15957
    May 2 '11 at 0:10
  • Network Damager tends to cause these types of issues in the first couple of weeks after every release. I suggest trying an earlier kernel too if that's possible. But you probably just have to wait for Network Damager to be fixed over the next few days unfortunately.
    – boehj
    May 2 '11 at 0:38

I used to encounter exactly the same problem, before 11.04, everything was fine with my AR2413 card, after upgrade, no more Wifi connection available. What I did to correct the problem was :

  • upgrade to the last kernel 2.6.38-10
  • remove everything in my /etc/network/interfaces that was related to my wifi network
  • delete the wifi connection in Network Manager
  • reboot ;)
  • recreate a Wifi connection with Network Manager
  • wait to get an IP
  • browse the Web with my Wifi connection :D

I think the major correction came from the new kernel ;)


I'm running exactly the same ethernet controllers (ath5k) on an Acer Aspire 5100 AMD Turion. Only since upgrading to 64-bit 11.04 (from 10.10) has wifi has been unacceptable, disconnecting at random, and continuously.

A few things that I've tried, which I have found, together, helpful in maintaining continuous wifi connectivity under 11.04:

  1. switch back to gnome 2 (classic);

  2. apt-get on wicd network manager; and

  3. boot from an older kernel, 2.6.35-28-generic, allowing menu select (thanks Dananjaya)

Hope this helps.

  • I guess this is what I will have to settle with, but technically this doesn't solve my problem. I want to use 11.04 as is with Unity and the whole shebang. There has to be a bug here somewhere, and I want to unearth it. I guess it is either in Network Manager or in Unity. Thanks for the answer though! May 30 '11 at 12:06

I have an Acer Aspire 5110 with Atheros AR2413 wireless chip. I have upgraded to Ubuntu 11.04 with kernel 2.6.38-10-generic.

The only thing that works for me is to boot the older kernel, 2.6.35-30-generic.

Using the 2.6.38-10 kernel, my system sometimes starts the wireless after some 30 minutes, sometimes never.

The NetworkManager applet menu comes with the entry "Wireless network" and the corresponding "disconnect" grayed out.

rfkill list says 0: phy0: Wireless LAN softblocked: no, hard blocked: no.

lspci says kernel driver in use is ath5k.

I have been unable to identify any meaningfull messages in /var/log/syslog relating to why this delay.

Messages that could be related:

NetworkManager: <info> (wlan0) bringing up device.
kernel: [ 49.256545] ADDRCONF(NETDEV_UP): wlan: link is not ready
NetworkManager: <info> (wlan0): preparing device.
NetworkManager: <info> (wlan0): deactivating device (reason: 2)
NetworkManager: supplicant_interface_acquire: assertion `mgr_state == NM_SUPPLICANT_MANAGER_STATE_IDLE' failed
NetworkManager: <info> modem-manager is now available.
NetworkManager: <warn> bluez error getting default adapter: The name org.bluez was not provided by any .service files
NetworkManager: Trying to start the supplicant...
NetworkManager: <info> (wlan0): supplicant manager state: down -> idle
NetworkManager: <info> (wlan0): device state chang: 2 -> 3 (reason 0)
NetworkManager: <info> (wlan0): supplicant interface state: starting -> ready
wpa_supplicant: Failed to initiate AP scan.

Identical or nearly identical mwessages appear also when running the older kernel, in which the wifi connection is established promptly. One second after the above messages, the following appears when using the older kernel:

NetworkManager: Activation (wlan0) starting connection 'My SSID'

No such message appeared last time I tried the new kernel. (Last time I also never got the wifi working.)

  • The syslog list became unreadable. I'll try again with some html formatting:
    – Cacadril
    Aug 23 '11 at 13:17
  • NetworkManager: (wlan0) bringing up device. <br> kernel: [ 49.256545] ADDRCONF(NETDEV_UP): wlan: link is not ready .......... Ugh, I give up formatting this text. The help says "Indent four spaces to create an escaped <pre><code> block", but I cannot get a new line and indent. Pressing enter just closes the editing window.
    – Cacadril
    Aug 23 '11 at 13:20

Haven't read the posts, but I got the same problems. I updated my driver to the madwifi driver and did some tests, Seems that Linux has no protection against high bandwith overload and it seems if you want to download to the top of your card's limit. I have seen speeds for a second that I never saw on any Windows machine. So I restricted the maximum bandwith and it is stable now. Before my connection dropped when roofing against my maximum bandwith. So in essence I think that the system guards against that and stops the WIFI connection. I tested this and could actually see it going up and reaching the roof it stopped.

Just my 2 cents worth..


Just switch your desktop to the classic view instead of Unity and your wifi will be back! It is a bug in Unity causing it to be unable to ativate wifi. Even though everything else is working fine, i.e. the drivers, the button, etc., there's a problems caused by the Unity interface.

Not the answer you're looking for? Browse other questions tagged or ask your own question.