2

I would like to install sqlite database browser from sourceforge.

I downloaded the file and unzipped it with tar -xvf sqlitebrowser_200_b1_src.tar.gz

Now it's a directory in my downloads with this structure:

| -- trunk
     | -- sqlitebrowser
          | -- sqlite_source
          | -- images
          | .. lots of files

From here how do I install the application?

2
4

The version on sourceforge is the same one available from repo on Trusty. I can't verify older releases.

cd ~/
mkdir junk
cd junk
apt-get source sqlitebrowser
sudo apt-get install devscripts
sudo apt-get build-dep sqlitebrowser
cd sqlitebrowser-2.0.0~beta1+ds.1/
debuild -us -uc

There, you built it from source.

1

Besides that you can install it building the source, you may want to install using the Software Center, it's simpler. Search sqlitebrowser, click on install and done.

search and install sqlitebrowser on the software center

0
0

It was an Qt project they use qmake (that comes with Qt development package) instead of configure.

"./configue" "make" "makeinstall" none of them work with that.

1
  • 2
    Please, write the full set of commands to enter in order. – Lucio Dec 1 '13 at 17:10
0

as you have downloaded the .gz file already now just have to configure and install it do the following steps-

I am considering that its downloaded into Downloads folder under home-

cd Downloads
tar -xvf sqlitebrowser_200_b1_src.tar.gz

After that you will get one more folder , thats the extracted folder to check it run-

ls -a

then use cd to enter in that extracted folder as-

cd name_of_extracted folder

then run the configure file as shown below-

./configure

and install it by using -

make
sudo make install

Thats it , if you will get any error paste it here in your question.

6
  • -1 without comment.. At least let me know whats the problem in my answer.. – Sukupa91 Dec 2 '13 at 5:05
  • did you installed sqlitebrowser using this method? – Avinash Raj Dec 2 '13 at 6:02
  • no , but it was on internet, its a .bin file , its the way to install as its not .gz , well am installing it now.. i will update it if needed or delete it if it wont work. but if someone is downvoting it . he should mention the reason. – Sukupa91 Dec 2 '13 at 6:07
  • yes,try that if it works then update your answer. – Avinash Raj Dec 2 '13 at 6:15
  • @AvinashRaj I have tested this myself , now i can say it is not going to work as there is no config file under extrected trunk folder.. so its better to delete this answer. just wanted to tell you , reply then i will delete it. – Sukupa91 Dec 2 '13 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.