Well, I'm pretty sure this has been asked lots and lots of times, I even looked at some previous questions but I couldn't do much with them, so I'm asking once more.

I have an WD external HDD, running Ubuntu 12.04. Starting yesterday the drive wouldn't auto-mount anymore and when I tried navigating to it I got this error message

Error mounting: mount exited with exit code 13: ntfs_attr_pread_i: ntfs_pread failed: > Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

Now, I'm not sure if the drive is formatted using NTFS. Anyway, I followed the suggestion, booted into Windows and tried running chkdsk /f, but Windows couldn't read the drive either, I got Data error (cyclic redundancy check). So I googled that and all the results point to my HDD failing. Great!

Some of the threads I found also contained the results of running fdisk, so here it is:

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xe0000000

Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63      144584       72261   de  Dell Utility
/dev/sda2          145408    21116927    10485760    7  HPFS/NTFS/exFAT
/dev/sda3   *    21116928   155336695    67109884    7  HPFS/NTFS/exFAT
/dev/sda4       155336702   488394751   166529025    f  W95 Ext'd (LBA)
/dev/sda5       483153920   488394751     2620416   dd  Unknown
/dev/sda6       289554432   483151871    96798720    7  HPFS/NTFS/exFAT
/dev/sda7       155336704   283283455    63973376   83  Linux
/dev/sda8       283285504   289540095     3127296   82  Linux swap / Solaris

Partition table entries are not in disk order

Disk /dev/sdb: 1499.6 GB, 1499598946304 bytes
255 heads, 63 sectors/track, 182315 cylinders, total 2928904192 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000389f4

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048  2928904191  1464451072    7  HPFS/NTFS/exFAT

One thread I read suggested using GSmartControl to read SMART data, but I couldn't get anything out of it.

I'm really considering sending it some professional company if I can't get it back to working state or can't recover the data by myself, but I want to try first. Any suggestions?

  • 1
    Try mount /dev/sdb /PATH/TO/EMPTY/DIRECTORY, as well as mount -t ntfs /dev/sdb /PATH/TO/EMPTY/DIRECTORY and mount -t hpfs /dev/sdb /PATH/TO/EMPTY/DIRECTORY. exFAT I think is still not supported. Try mounting it, copying the data off, and using GParted to reformat it. What sort of external HDD is it? If there is an extra cable to plug into to provide more power plug it in before attaching the USB/eSATA cable. Is it eSATA or USB (or eSATAp even...). You may need to plug it in as an internal HDD, and then run GParted off a live cd - gparted.sourceforge.net/livecd.php – Wilf Dec 1 '13 at 16:07
  • I tried both commands, mount -t ntfs /dev/sdb /PATH/TO/EMPTY/DIRECTORY got me this: NTFS signature is missing. Failed to mount '/dev/sdb': Invalid argument The device '/dev/sdb' doesn't seem to have a valid NTFS. Maybe the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around? – Felipe Ruiz Dec 1 '13 at 17:34
  • mount -t hpfs /dev/sdb /PATH/TO/EMPTY/DIRECTORY got me: mount: wrong fs type, bad option, bad superblock on /dev/sdb, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so – Felipe Ruiz Dec 1 '13 at 17:36
  • Sorry mount /dev/sdb1 /PATH/TO/EMPTY/DIRECTORY, mount /dev/sdb1 -t ntfs /PATH/TO/EMPTY/DIRECTORY, mount -t hpfs /dev/sdb1 /PATH/TO/EMPTY/DIRECTORY, - for some filesystems types it may select the first partition. The error messages will appear occasionally if you do not specify the partition. You also don't have to actually run it with PATH/TO/EMPTY/DIRECTORY, you can put the path to an empty directory. For instance. Run sudo mkdir /media/harddisk123 to create an empty directory, and then run mount /dev/sdb1 /media/harddisk123. You have to create the directory first. – Wilf Dec 1 '13 at 18:36
  • I had created the directory before trying to mount. Anyway, I tried mounting sdb1 now, the first and second commands give me the same error I posted on the question, ntfs_attr_pread_i: ntfs_pread failed: Input/output error and the third one had the same result as last time, wrong fs type – Felipe Ruiz Dec 1 '13 at 19:00

You could be able to backup the disk using dd:

sudo dd bs=4M if=/dev/sdb of=filename.img
sudo dd bs=4M if=/dev/sdb | gzip > filename.gz

The first command will create a 1499.6 GB (referring to your fdisk output) size image, the second will create something slightly smaller - which would not fit onto the 250GB sda drive...

It still might show up in GParted, but something that big would take ages to scan...

Using a different external HDD case could help (if it is the more normal sort of hard drive that will work in a various setups), or a different way of connecting.it..

You probably shall have to take it to some professionals, and get it fixed (or, just recovered) that way. That is may be the simplest way to do it, if the most expensive - but mucking around with 1.5 Terabytes of data could be rather difficult - particurally with input/output errors.

This is sort of referring to past experience, where my 1 Terabyte Hitachi drive I used to store videos on failed after a month, and it turned out to be the external USB enclosure that was the problem. I eventually sorted it out for myself last week, but I only recovered a 1/4 of the data, and only 3/4 of the disk now works. I can now still use it though - but not for anything important.

But I do have one or two 'tips':

  • If it is important, backup the backup - and don't use massive hard drives or partitions for backing up
  • Check the disk occasionally (GParted is usually competent at that)
  • 'Safely Remove Drive' before unpluggin it
  • Never let the computer suspend when it is plugged in (that is what killed mine)

Sorry, thats it sad

| improve this answer | |
  • I'll do that as soon as I buy another hard drive. Suppose I'm able to get the image, how do I get the files? Also, do you recommend using dd vs ddrescue? – Felipe Ruiz Dec 6 '13 at 17:49
  • ddresuce may be better - askubuntu.com/questions/211578/… - but if you do create an image as backup, you should be able to extract the files from it or mount the file as though it was a hard drive, though this will not work if the drive is very corrupt - input/output errors etc... – Wilf Dec 6 '13 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.