Apparently, there's a bug in Upstart that's shipped with Ubuntu 13.10, which overrides the umask set either through $HOME/.profile or /etc/login.defs.

Upstart has been updated to fix this in Trusty, but how do I go about it in Ubuntu 13.10?

The bug report mentions creating an Upstart override job in $HOME/.config/upstart for whatever session you happen to be running. How would one do this?

The report also mentioning disabling Upstart for the user session, which would be the way things worked pre-13.10 if I've understand things correctly. But are there any side effects to this?

How can I find out if the updated Upstart will find its way to 13.10?

2 Answers 2


I seem to have solved this. Here's what I did:

  1. I copied gnome-session.conf from /usr/share/upstart/sessions to gnome-session.override in $HOME/.config/upstart
  2. I edited gnome-session.override and added umask 0002 on the line before exec gnome-session --session=$DESKTOP_SESSION
  3. I edited $HOME/.bashrc and added umask 002 to the end of the file

Step 2 made newly created files within the desktop session writable, but the umask for the terminal seemed to remain 0022, which prompted step 3. I repeated these steps for the other users as well.

Comments are very welcome, as I'm not a sure this is the best solution.


Try installing upstart 1.11-0ubuntu1 from Trusty; it worked for me.

  1. Download latest published package for your architecture:

  2. Install with:
    sudo dpkg -i upstart_1.11-*.deb

  3. Reboot.

  • I'd rather not install packages in this way. Certainly not with a core package. But I thank you for your suggestion!
    – fohswe
    Dec 21, 2013 at 15:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .