1

After installing Ubuntu 13.10, I can only load GRUB if I have the LiveUSB I used connected.

What happens is I get a black screen with "Read Error". To circumvent this error, booting up with the USB connected, GRUB loads up completely fine and off I go. I don't even have to manually boot up the USB.

I have tried two solutions with no luck.

  1. sudo grub-install sda
  2. Automatic Boot-Repair

Neither solves my problem.

Fresh boot-repair log

Few things to note:

  • I've just added a 3TB hard drive recently and reinstalled absolutely everything. However, the problem I am having has existed on my last installation, too. Just saying this in case someone makes the relation and this information helps.
  • Ubuntu is on an SSD
  • Windows is installed on a my second hard drive, so Grub isn't detecting it. I haven't solved this yet, if you guys notice that in the log.
  • While I understand that this may appear to be a duplicate question, no solution they give has been successful. I hope that this changes the fact.

Edit: It's quite late now. I'll be heading to bed, so I'll respond to any replies whenever I can.

1

Solved it eventually.

Had to go into BIOS and disable Quick Boot. Don't have any understanding of why that broke it, but it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.