1

I'm using Dell Latitude E5530 running Ubuntu 13.04 and I have problems with connecting to some WiFi networks. While I am able to connect to most of WiFi, in some cases system is repeatedly asking me to provide WPA / WPA2 Personal password and eventually doesn't connect.

My kernel is:

3.8.0-33-generic

And my network card details are:

02:00.0 Network controller [0280]: Broadcom Corporation BCM43228 802.11a/b/g/n [14e4:4359]
0c:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5761 Gigabit Ethernet PCIe [14e4:1681] (rev 10)

I've already tried this solution but it completely disabled any wifi so I went back. I am currently using bcmwl-kernel-source proprietary drivers.

Any help will be greatly appreciated.

  • When you tried brcmsmac instead of wl, were there any informative messages here, especially about firmware? dmesg – chili555 Dec 1 '13 at 16:38
  • Haven't tried it then, but now dmesg gives me [ 2.672591] eth1: Broadcom BCM4359 802.11 Hybrid Wireless Controller 6.20.155.1 (r326264). – Mariusz Bąk Dec 2 '13 at 10:30
  • Would you please try again the suggestion you linked, unloading wl and loading brcmsmac, and then check dmesg for any reasons it isn't working as expected? – chili555 Dec 2 '13 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.