I just upgraded and was excited to try Unity. I logged in normally, but got the following symptoms:

  • Although my background image showed normally, all my icons and any windows I opened flickered in and out every few seconds
  • I opened a Terminal window with a keyboard shortcut, but couldn't type anything in it
  • I didn't see any menus for shutting down or logging out, so I had to do so with the power button

After rebooting, I tried Recovery Mode, but that eventually went to a black screen and did nothing else.

I succeeded in booting by doing this:

  • Boot to "normal" Ubuntu (not Recovery Mode)
  • Choose my user name
  • While the password box is on the screen, choose "Ubuntu Classic" from the menu at the bottom
  • Log in

Everything looks fine now, but I'm using GNOME and not Unity. How can I diagnose my issues with Unity and get it working?


Without knowing your graphics hardware I suspect you cannot run Unity, when you log into GNOME open a terminal and type the following;

/usr/lib/nux/unity_support_test -p

It will let you know if your hardware supports Unity, if you get a NO response at the end you can always install Unity2D:

You can then log out and Select Unity 2D at the log in screen

  • When I ran that test, it showed all passing. Should I report a bug? – Nathan Long May 3 '11 at 1:38
  • Unity 2D works for me, by the way. Thanks! – Nathan Long May 7 '11 at 1:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.