I want to upgrade my Ubuntu 13.04 to Ubuntu 13.10. I'm unable to do via GUI.

[ The reason why I'm unable to do so:

Via software updater, I proceed ahead and click upgrade (for upgrading my OS). I authenticate by providing my password. Then it proceeds and downloads upgrade tool. That time only (while downloading the tool) error message comes "system program problem detected". It then doesn't proceed ahead and I click to report the problem ]

So, I tried via command line but here also I couldn't succeed upgrading my OS. For the same I ran

$ sudo apt-get update

Then I ran

$ sudo apt-get dist-upgrade

And then:

ravbholua@ravbholua-Aspire-5315:~$ sudo do-release-upgrade
Checking for a new Ubuntu release
Get:1 Upgrade tool signature [198 B]                                                                                                 
Get:2 Upgrade tool [1,135 kB]                                                                                                        
Fetched 1,135 kB in 6s (32.9 kB/s)                                                                                                   
authenticate 'saucy.tar.gz' against 'saucy.tar.gz.gpg' 
gpg exited 2
Debug information: 

gpg: Signature made Friday 01 November 2013 10:34:27 AM IST using DSA key ID 437D05B5
gpg: Can't check signature: public key not found

Authentication failed
Authenticating the upgrade failed. There may be a problem with the network or with the server. 

Please suggest how to go ahead and upgrade my OS.

migrated from unix.stackexchange.com Nov 29 '13 at 20:50

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems.

  • Why are you unable to do it via the GUI? Which error messages do you get there? – l0b0 Nov 29 '13 at 13:43
  • @l0b0 I have updated my Q with the reply to your Q. – Ravi Nov 29 '13 at 15:29

Try this:

gpg --keyserver keyserver.ubuntu.com --recv 437D05B5
apt-get update 

Otherwise you might be able to use this blogpost:

The solution
After a bit of head scratching, it seems the simple solution is to delete all of the GPG keys in /etc/apt and re-run apt-get update.

cd /etc/apt
sudo mkdir gpgbackup
sudo mv *.gpg gpgbackup/
gpg --export -a 437D05B5 | sudo apt-key add -
sudo apt-get update

(added backing up instead of plain rm)

  • You have missed one important point in your codes. You have taken backup but missed deleting the gpg files. After deleting the files, I have also get rid of the annoying messages " no public key ....". I'm trying whether now I can upgrade my OS to Ubuntu 13.10. I will update after that. – Ravi Nov 30 '13 at 8:29
  • Thank you very very much. It's working. I'm able to upgrade my current Ubuntu 13.04 to 13.10. I canceled the upgrade as it's going to take many hours due to my slow Internet connectivity. I will do at night so that when I wake up tomorrow morning it would have completed. Great Thom Wiggers!! One thing I would like to add: While upgrading, it popped up a message "Some 3rd party entries in your sources.list were disabled. You can re-enable them after the upgrade with the 'software-properties' tool or your package manager." – Ravi Nov 30 '13 at 9:09
  • That's ppa's you installed and maybe some software from the software center. Just do exactly what it said in the popup to reenable them. – Thom Wiggers Nov 30 '13 at 11:22


sudo apt-get update && sudo apt-get dist-upgrade
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 437D05B5 3E5C1192
sudo gpg --keyserver keyserver.ubuntu.com --recv-keys 437D05B5
sudo gpg --no-default-keyring -a --export 437D05B5 | gpg --no-default-keyring --keyring ~/.gnupg/trustedkeys.gpg --import -

Then, 2 options:

Option A:

Use sudo update-manager -d and you'll get there by GUI.

Option B (command line only):

Install the update-manager-core package if it is not already installed:

sudo apt-get install update-manager-core Edit the file /etc/update-manager/release-upgrades,

sudo nano /etc/update-manager/release-upgrades and set Prompt=normal below # determine if a newer release is available.. This would look like this:

#  lts    - Check to see if a new LTS release is available.  The upgrader 
#           will attempt to upgrade to the first LTS release available after > >     #           the currently-running one.  Note that this option should not be > >     #           used if the currently-running release is not itself an LTS 
#           release, since in that case the upgrader won't be able to 
#           determine if a newer release is available. 

Now run sudo do-release-upgrade -d and follow the instructions.

  • What it means please: ` set Prompt=normal under # determine if a newer release is available.` That file contains all sentences with # in the beginning (i.e. they are commented) except the last one. The last sentence is: Prompt=normal – Ravi Nov 29 '13 at 15:38
  • Then you don't need to do anything as Prompt already equals normal.. – PMint Nov 29 '13 at 20:21
  • Check out my edit. – PMint Nov 29 '13 at 20:28
  • As that file remains unchanged, what procedure you told is what I had tried and mentioned in my Q. Just now also again I ran sudo apt-get update && sudo apt-get dist-upgrade then sudo do-release-upgrade -d. The same error I got as shown in my Q. – Ravi Nov 30 '13 at 5:36
  • What about way A? – PMint Nov 30 '13 at 6:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.