10

I've tried to install maybe ten Linux distros on my new PC, and every time I have problems with video drivers: black screen or visual artefacts.

I was able to install only Ubuntu 12.04.3 64-bit, but also with problems: black screen on startup (sometimes all was normal when I used Live mode before install, sometimes I was not able to load Live Mode - Ubuntu says that I have problems with video and gives me a choice with four elements, one of them "use safe graphics mode", but I even can't choose this - the system is frozen).

In tty I installed nvidia-current, but it didn't help me. Every boot I need to press ESC and enter rescue mode and just press Resume and after this the system boots normally. If I try to do a normal restart I get a black screen after Ubuntu logo again.

I tried switching nvidia driver in the options - I have version 319-updates and version 319 [Recommended], but neither works.

I have Palit GeForce GTX650, all updates.

My dmesg output

Output of dpkg --get-selections | grep 'nvi\|nou'

My /boot/grub/grub.cfg

  • did you blacklist or uninstall the Nouveau driver? – Anders F. U. Kiær Dec 11 '13 at 19:40
  • Not uninstall. I need? – Vitaly Zdanevich Dec 11 '13 at 20:11
  • could be worth a try, sudo apt-get --purge remove xserver-xorg-video-nouveau – Anders F. U. Kiær Dec 11 '13 at 20:20
  • 1
    can you add the output of dpkg –get-selections | grep 'nvi\|nou' to the question and the output of dmesg to paste.ubuntu.com and add the url in the question? – Anders F. U. Kiær Dec 12 '13 at 14:56
  • 1
    Could you please post your /boot/grub/grub.cfg? I think you miss the nomodset kernel parameter from your kernel command line. – falconer Dec 14 '13 at 7:43
17

The proprietary nvidia driver should be used without KMS. You have to edit the /etc/default/grub file, use your favourite text editor (vi, nano, gedit, etc.):

sudo vi /etc/default/grub

Change the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" line to the following:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Save the file, then run sudo update-grub Then reboot, and it should work.

If it still doesn't solve it, then remove also "quiet splash" from the previous line, and again sudo update-grub. (This will disable the graphical boot screen.)

The recovery booting did work, because the recovery menu entry had the nomodeset parameter.

  • It is not important, but I can't enter into tty when pressing CTRL+ALT+F1: I see only black screen and after few seconds my display turn off. – Vitaly Zdanevich Dec 19 '13 at 8:44
  • @VitalyZdanevich Please add the vga=normal parameter also to that line. If still no good add the video=vesa:off parameter also. Note that after this you tty resolution will be decreased, but this can't be resolved with the nvidia drivers AFAIK, which only supports text mode tty. If still no success remove quiet splash to disable graphic boot. – falconer Dec 19 '13 at 9:23
  • I don't know - it's related to this problem or not, but now I can't shut down my PC - my computer rebooting instead of power off. – Vitaly Zdanevich Dec 22 '13 at 19:42
  • @VitalyZdanevich It shouldn't cause such problems, all of these kernel parameters only deal with display. But the best is to test and try out with different parameters and see if one of these are the faulty one. What kernel parameters are you using now? You may also try adding the "acpi=force" kernel parameter. (or maybe the contrary acpi=off"). Or try disabling wake-on parameters in the BIOS. (wake-on-lan, wake-on-key,etc.) This is what you could try in my opinion. If none of these solves your problem, then ask another question on the site. – falconer Dec 22 '13 at 20:35
0

This is X Server error. If X Server update itself then it will also delete the path of the graphic driver. The only way perhaps is to install what Ubuntu has to offer (namely drivers in 'Additional Drivers').

I have AMD A10 with AMD Radeon HD8650 with CrossFire AMD Radeon HD 8970m and installed a driver found in AMD websites, after an updates, the X server failed. I have to reinstall 'fglrx' (AMD drivers for Ubuntu) and the X server works again, only this time, it couldn't identify my 8970m, but identify it as other AMD GPU.

I'm not sure about nVidia, but my advice is try not to install anything beyond what Ubuntu gave you. If it's from Ubuntu, higher chances are it will work.

  • Ubuntu not offering me anything - I already have installed from tty Nvidia driver. – Vitaly Zdanevich Dec 7 '13 at 15:04
0

So this GTX650 Geforce card of Nvidia has CUDA-Technology as I see in description at website of nvidia.com

Here I posted a workaround for CUDA-cards, which normally refers to Ubuntu 12.10 and worked there fine:

How can I Install Nvidia Driver GT 520 and Cuda 5.0 in Ubuntu13.04?

It is humblesome, but not too tricky.

This workaround normally concerns hybrid-cards of nvidia, but I don't see, why it should not work with your card.

0

In the grub boot menu i chose an earlier kernel version and managed to boot into my os. I think this is because the nouveau drivers were loaded instead of the nvidia drivers.

0

Change the GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" line to:

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

Save the file, then run sudo update-grub Works great for nvidia 307. You loose only purple startup screen, but you'll see how is system starting.

0

I had same problem with 2 laptops with similar Nvidia cards.

The solution I have found after trying many Ubuntu flavors with similar problem is to install fresh Kubuntu, and then, before you perform any software updates, use the Synaptic Package Manager, filter for nvidia and go to package / force version and keep nvidia filtered packages to the installed version in order to prevent them from upgrading.

Then, you can install other desktop flavors if you want (I have tested adding in second step my favorites GNOME and Xfce without any problems). I think, if my memory serves me well, the Nvidia driver used and kept using is 173.x (or 176.x).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.