5

I have a Vaio VPCCW21FX with a brand new installed Ubuntu 13.10 and I'm trying to connect a Wedge Mobile keyboard. So I went into the system settings, bluetooth and tried to turn it on but as soon as I click on the switch, it stays on for 1 or 2 seconds and then it goes back to the off position automatically...is there any compatibility issue? What can I do?

8

First Check the Output for rfkill list all it will tell you about the issue, if its fine use -

rfkill unblock bluetooth  - to start bluetooth 

and

rfkill block bluetooth  - to stop bluetooth 

it has already solved your issue , just wanted to make an answer for future reference.

1

First of all, check that your bluetooth was unlocked on rfkill.

sudo rfkill list

In case your bluetooth is Soft blocked you can unblock it by running the below command,

sudo rfkill unblock bluetooth

In case your bluetooth is Hard blocked,then try to find a hardware switch on your laptop to unblock it.

  • it looks like rfkill unblock bluetooth and rfkill block bluetooth are they same ?? – Sukupa91 Nov 28 '13 at 17:11
  • avinash, with your command i get start: Job is already running: bluetooth but with sushantp "unblock" command it is now working!! and i have the icon in the upper bar!! thanks :) why it was "blocked"?? – Mariano Nov 28 '13 at 17:21
0

Install and configure urfkill. This seems to work for my Dell:

# cat /etc/urfkill/urfkill.conf |grep '^[[:alpha:]]\|\['
[general]
user=root
master_key=true
force_sync=true
persist=true

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.