0

Every time I try to install ndiswrapper-dkms, I get a crash report saying,

Title: "ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to build"

DKMSBuildLog: "DKMS make.log for ndiswrapper-1.57 for kernel 3.8.0-33-generic (x86_64) -date and time-

Cannot find kernel build files in

/usr/src/linux-headers-3.8.0-33-generic

Please give the path to kernel build directory with the KBUILD= argument to make

make:[config_check] Error 1

1

Not sure if this problem has been resolved yet. I had a similar issue and followed Chili555's instructions: http://ubuntuforums.org/showthread.php?t=1967383

The very first one worked for me: sudo apt-get install --reinstall ndiswrapper-common ndiswrapper-utils-1.9

I also upgraded to 12.04 3.11 after resolving this issue by following these instructions: http://www.leaseweblabs.com/2013/07/upgrade-ubuntu-12-04-lts-kernel-to-3-4/

My wifi is behaving erratically (was behaving this way prior to making the above changes) but have not encountered any ndiswrapper issues since.

Hope this helps

0

try 1.58 ndiswrapper 1.58rc1 source code from http://sourceforge.net/projects/ndiswrapper/files/testing/

make a folder xxx in home and extract downloaded source code in that

then use

cd xxx

and then

sudo make install

When it's finished, it'll be installed permanently.

check if it works else its a well known bug well there is a workaround a found , try to install it manually as follows-

1.Download the latest tarball from http://sourceforge.net/projects/ndiswrapper/files/testing/

2.Create the folder /usr/src/ndiswrapper-1.58/

3.Extract it any where and copy it the previously made folder thats /usr/src/ndiswrapper-1.58/ , dont copy the directory itself , just copy the content.

4.Copy the dkms.conf file from /usr/src/ndiswrapper-1.57/ to the /usr/src/ndiswrapper-1.58/ folder as well. Open it with a text editor and change the version of ndiswrapper listed there to 1.58.

5.Run these commands in your console in order to build and install the module using dkms:

sudo dkms add ndiswrapper/1.58
sudo dkms build ndiswrapper/1.58
sudo dkms install ndiswrapper/1.58

hope it will work. try it if you will get any other problem. Let me know.

  • Cannot find kernel build files in /usr/src/linux-headers-3.8.0-33-generic Please give the path to kernel build directory with the KBUILD=<path> argument to make make[1]: *** [config_check] Error 1 make[1]: Leaving directory `/var/lib/dkms/ndiswrapper/1.58rc1/build/driver' make: *** [driver] Error 2 – Nicole Nov 28 '13 at 6:49
  • means the problem is still there? – Sukupa91 Nov 28 '13 at 6:50
  • Seems to be the same problem. I tried reinstalling the linux-headers-3.8.0-33-generic package and it didn't help. – Nicole Nov 28 '13 at 6:52
  • The problem is in the ndiswrapper source, Updating to the newer 1.58rc1 version can fix the bug. thats what i am trying to explain. – Sukupa91 Nov 28 '13 at 6:54
  • I just did that, and the above was my result. I'd show the whole thing if there wasn't a character limit. – Nicole Nov 28 '13 at 6:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.