0

I have Ubuntu 13.10 Desktop as host and Ubuntu 12.04.3 Server as guest. On guest OS VirtualBox setting I have setup 3 adapter, the first is connected to NAT, the 2nd to Host-Only, and the 3rd to internal network because I planned to add another guest. The problem is in Ubuntu 12.04.3 Server (the guest OS) the only adapter available is eth0, how do I configure eth1, eth2, and so on? enter image description here

0

With VMWorkstation, I needed to:

  1. Add the virtual adapter(s) via the main VM Network Editor, with DHCP enabled.
  2. Remove and reinstall Ubuntu Server for it to recognize the additional adapter(s)
  3. The DHCP configuration is saved in the /etc/network/interfaces configuration file, but the file is read only. Modify attributes on file to make it read write. (chmod 666 <filename>)
  4. The edit the etc/network/interfaces file to add the additional interface(s) to use DHCP:

    auto eth1
    iface eth1 inet dhcp
    
  5. Issue the sudo service networking restart command to re-enable the network interfaces.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.