1

I installed Ubuntu 12.04 LTS on my old sony Vaio VGN-FJ170. My problem is that laptop can't detect the press of Fn key. I investigated a bit and found that at least some functionality of sony-laptop module in kernel works - display brightness could be changed through Ubuntu settings (and it works through changing setting file in /sys/devices/platform/sony-laptop.

I tried to see if os could detect Fn+2=F2 and other things by using acpi_listen, no luck.

Thank you, Alex

Update. Did some testing and found following: Sony-laptop driver actually works.

After pressing FN+Fkey combination file /sys/devices/platform/sony-laptop/fnkey changes with specific codes: Fn+F2 - (audio mute) - fnkey value is 1; Fn+F3 - (Vol down) - fnkey value is 2; Fn+F4 - (Vol Up) - fnkey value is 4; Fn+F5 - (Brightness down) - fnkey value is 8; Fn+F6 - (Brightness up) - fnkey value is 16; Fn+F7 - (Video output change) - fnkey value is 32; Fn+F10 - (Zoom) - fnkey value is 1024; Fn+F12 - (Sleep) - fnkey value is 64; No other key combination changes value of /sys/devices/platform/sony-laptop/fnkey

I guess it is possible to write a daemon which will watch content of this file and translate it to something, which in turn could be detected by window manager and used to trigger keyboard shortcuts... But this is well beyond my capabilities... Could someone please help?

Changing of brightness works as well, but I don't know how to actually tie it to daemon or somehow make it accessible through GUI...Here is the details: File /sys/class/backlight/sony/brightness controls actual brightness of the screen (values are integers from 0[lowest] to 7[highest]).

Command sudo sh -c 'echo "0" > /sys/class/backlight/sony/brightness' will change it to the lowest setting.

Please help me to utilize this in GUI. Thank you in advance!

Second update. I tried to watch for key press event. No success in both acpi_listen and xev...

0

1 Answer 1

0

I have similar problems with an Asus q500a. It reads all my f keys correctly, and some of the fn+f combos work, but some of them are read as letter keys, except they do not release. Do you have the same problem? I have been looking at https://wiki.ubuntu.com/Hotkeys/Troubleshooting but having trouble sorting it all out. Let me know if you have any luck!

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.