On both 13.4 (and now after upgrading to 13.10) I find that I can not cycle the machine with a reboot because during the shutdown process the step of "Killing all remaining processes" fails:

enter image description here

I can force a reboot with reboot -f that works but I don't want to reboot without the benefit of a graceful shutdown process (which the -f imposes). I guess it's also worth stating that the only major software that I've put on top of the base Ubuntu install is:

  • mySQL 2.4.6
  • Couchbase 2.1.x
  • PHP 5.3.x

As you can see from the screenshot it appears that mySQL and Couchbase have successfully shutdown and obviously PHP isn't a server process so I'm a little bit unsure what to do next.


You are using reboot now which will drop you into maintenance mode. This is not a bug but can be confusing. If the command doesn't have any explicit option to it, it will drop into maintenance mode. Therefore please use shutdown -r now but if you feel this is a bug please comment here.


  • could it be located anywhere else? I don't have anything at /var/log/messages – ken Nov 27 '13 at 16:38
  • try /var/log/syslog - sorry – K2Chris1983 Nov 27 '13 at 17:06
  • ok, the last item in the log is the only mildly suspicious item: Nov 27 09:56:17 ubuntu rsyslogd-2039: Could not open output pipe '/dev/xconsole' [try http://www.rsyslog.com/e/2039 ]. It's worth noting that I'm using a headless configuration which doesn't use X. – ken Nov 27 '13 at 18:13
  • I have found reference to /dev/xconsole in /etc/rsyslog.d, also this is an interesting read: bugs.launchpad.net/ubuntu/+source/rsyslog/+bug/459730. Am going to remove and see where this leaves me. – ken Nov 27 '13 at 18:15
  • 1
    Try this shutdown -r now instead of reboot – K2Chris1983 Nov 27 '13 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.