4

how to add WPA2 Enterprise connection over TLS in Kubuntu 10.13, using its standard network manager? I want to connect to my university’s eduroam network and cannot do it.

When I try to do it in connections editor, when I do “add wireless connection”, after filling all necessary data (network’s ssid and security details with WPA2 Enterprise over TLS authentication) after clicking “OK” nothing happens. No connection’s being added.

When I add some empty connection (only ssid filled, no security checked) it is being added to connections list, and I can edit it, but again after inserting security data it does not save changes. So I cannot configure this connection.

Details I try to insert:

Security: WPA & WPA2 Enterprise
Authentication: TLS
Identity: my.identity@student.put.poznan.pl
User’s certificate: [None]
CA certificate: [path/to/cacert.pem]
User’s private key: [path/to/user.p12]
User’s key password: [pass]

What are other ways to set the connection?

1
  1. Create new connection to eduroam without setting security options (just to get connection file with UUID etc.)
  2. Edit /etc/NetworkManager/system-connections/<connection_name_from_point_one> as root
  3. Delete everything but connection, ipv4, and ipv6 sections
  4. Add:

    [802-11-wireless]
    ssid=eduroam
    mode=infrastructure
    security=802-11-wireless-security
    
    [802-11-wireless-security]
    key-mgmt=wpa-eap
    
    [802-1x]
    eap=tls
    identity=XXXXXXXX@student.put.poznan.pl
    client-cert=file:///path/to/your/private/key/XXXXXXXX@student.put.poznan.pl.p12
    ca-cert=file:///path/to/ca-cert/cacert.pem
    private-key=file:///path/to/your/private/key/XXXXXXXX@student.put.poznan.pl.p12
    private-key-password=XXXXXXXX
    system-ca-certs=false
    

    I think client-cert can be any file. The network doesn't need this, but NetworkManager does.

-1

Apparently if you skip the user certificate, Network Manager won't save the configuration. Try to use the same certificate for both CA certificate and User certificate.

  • This will not work - user certificate is specific to each user, CA is a different cert. – Thomas Ward Dec 13 '16 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.