1

I just installed natty from scratch. If I use the nvidia-current driver, I cannot login. The unity bar loads on the left, but the status area never comes up and the UI never becomes responsive.

If I downgrade to nvidia-173, I am able to log in. The only problem I seem to have with nvidia-173 is that if I switch to the tty (ctrl+alt+f1) and switch back, the graphics are horribly corrupted. The applications re-draw but the backgroud is permanently corrupted.

Any ideas on the issue?

lspci output for my card:

05:00.0 VGA compatible controller: nVidia Corporation G71 [GeForce 7300 GS] (rev a1) (prog-if 00 [VGA controller])
Subsystem: eVga.com. Corp. Device c437
Flags: bus master, fast devsel, latency 0, IRQ 18
Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at fb000000 (64-bit, non-prefetchable) [size=16M]
[virtual] Expansion ROM at fc000000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: nvidia
Kernel modules: nvidia-current, nvidia-173, nouveau, nvidiafb
1

Maybe this could be helpful for solving your problem:

It is a similiar problem like mentioned here (with a workaround): Geforce Go 7300/7400 blacklisted, can I still run Unity? Geforce Go 7300/7400 blacklisted, can I still run Unity?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.